Bug 53965 - rmmod -as writes messages to console
rmmod -as writes messages to console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 13:43 EDT by Robert M. Riches Jr.
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:05:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert M. Riches Jr. 2001-09-24 13:43:11 EDT
Description of Problem:
"/sbin/rmmod -as" writes messages to console rather than
via syslog, whether done via /etc/cron.d/kmod or manually.
The -s switch is supposed to use syslog rather than the
console for messages.  The specific messages I am getting
on the console are from "bttv0" and "i2c-core.o".  (I can't
cut-and-paste the full text, because the console and X are
mutally exclusive.)  I suppose the messages in question
might actually be coming from the modules themselves rather
than from rmmod, in which case this report should be moved
appropriately.

Version-Release number of selected component (if applicable):
modutils-2.4.2-5

How Reproducible:
appears reasonably reliable, but now known for certain

Steps to Reproduce:
1. manually run "/sbin/rmmod -as" once or twice after using xawtv.

or

2. use xawtv
3. log out and let the system sit for a day or three

Actual Results:
Messages about "bttv0" and "i2c-core.o" being unloaded
and/or unregistered are printed to the console.

Expected Results:
Such messages should be sent via syslog.

Additional Information:
Comment 1 Bill Nottingham 2002-01-24 23:32:52 EST
They are almost certainly coming from the modules themselves.
Comment 2 Arjan van de Ven 2002-01-25 04:15:01 EST
Can you paste a message ? if I have the text I can silence it.
(Note that I recommend removing the kmod script completely!)

Note You need to log in before you can comment on or make changes to this bug.