Bug 539709 - [drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 533156 547288 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-20 16:04 EST by Orion Poplawski
Modified: 2010-07-25 05:39 EDT (History)
39 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 05:50:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (46.20 KB, text/plain)
2009-11-20 16:04 EST, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2009-11-20 16:04:45 EST
Created attachment 372606 [details]
dmesg

Description of problem:

Does not appear to be any real problems, just don't like kernel error messages.
Occurs at boot.

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

Version-Release number of selected component (if applicable):
2.6.31.5-127.fc12.x86_64
Comment 1 Juraci Paixão Kröhling 2009-11-21 06:08:37 EST
The same error message appears when trying to boot the Live i686 image into Mac Mini (Intel).
Comment 2 Alistair McKinlay 2009-11-27 18:25:44 EST
I can confirm this happens when booting the live i686 image onto my Toshiba Satellite Pro L20.

It then stops booting.
Comment 3 Peeths 2009-11-28 14:23:53 EST
I get the same error message when i tried booting my notebook SONY VAIO VGN-FJ270 from a live USB. This is when I used the Fedora 12 i686 as the live image, before I have fedora 10 i686 and was booting the machine without any issues form the live usb. I have another distro in the notebook . is it because of that .

the booting stops after i get this error message. This error message is followed by another message whih is 

Boot has failed, sleeping forever
Comment 4 Geert Jansen 2009-11-29 12:46:03 EST
Same problem on Samsung NC10 netbook with Lenovo external USB DVD drive.

Works if i boot from a USB stick that is created from the same media using livecd-iso-to-disk.
Comment 5 Robert Hoekstra 2009-12-03 02:11:54 EST
Same here,

kernel version 2.6.31.6-145.fc12.i686.PAE
ATI Technologies Inc M56P [Radeon Mobility X1600]
Comment 6 soren riise 2009-12-06 17:57:30 EST
Got same problem with fc12 i686 on USB -- prior to that the system was hanging after a few sucesful boots from the USB key.

Using Compaq laptop 6910p w a HP 4gb USB key for LIVE boot image.
Comment 7 Vedran Miletić 2009-12-07 06:57:11 EST
I don't have that issue on my HP 6710s, but my friend has on his Toshiba A300-1MM with Intel 4500M Graphics (non-HDMI version).

I would bet it's Intel specific, and that comment #5 is a different bug.
Comment 8 Robert Hoekstra 2009-12-07 08:26:45 EST
@  Vedran Miletić: Should I start a new bug report then?

I notice that my machine doesn't stop booting, so it might as well be a different bug...

Complete lines with errors are (I have two screens attached):
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
Comment 9 Ryan H. Lewis (rhl) 2009-12-07 19:38:57 EST
I can confirm the same issue on my Fujitsu Tablet T4215, Intel Core 2 Duo, i686 version of fedora 12 with KDE off the main website, loaded using unetbootin to a flash drive.

My machine is x86_64, I am retrying now with the x86_64 version, and I have the same error.
Comment 10 xl 2009-12-12 02:42:17 EST
I have the same error, my machine is HP6510b, kernel is 2.6.31.6-127.fc12.x86_64.
OS is installed in USD disk.
Comment 11 Nickolay Bunev 2009-12-12 07:50:56 EST
I've experienced the same error ([drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own) and the machine stop booting with (Boot has failed, sleeping forever)
The notebook is Toshiba Portege R500. I am trying to boot KDE Live x86_64 CD image.
lspci -v | grep VGA:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 12 Ahmad Zulkarnain 2009-12-12 14:27:42 EST
Laptop model: Asus K40IJ
Running fully updated F12 native on /dev/sda1 with the other OS on a extended partition.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
$ uname -r
2.6.31.6-166.fc12.i686.PAE

dmesg snippet
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own

consistent with above comments. X still boots per normal with no noticeable issues.
Comment 13 Arkaitz 2009-12-13 18:34:23 EST
I have an Asus eeepc 901 and it stops on booting, but only with the eeepc modified kernel from fedora-eee.com . The same message appears using dmesg, but nothing noticeable happens. It only happens to me with F12, so I will downgrade myself back to F11 again :)
Comment 14 Ryan H. Lewis (rhl) 2009-12-13 18:47:53 EST
I used F12 a few days later (The KDE live-cd) and it managed to work.. I've been working for a few days now, the bug still appears in dmesg, but it's not causing any noticeable issues.
Comment 15 Marie Henri Beyle 2009-12-14 05:27:13 EST
Can you boot the system in text mode?

When Fedora shows grub init screen you can press the "a" key and add the "3" number at the end of the kernel boot options. Then you can boot in text mode (init 3).

I have the same error ([drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own) in a Toshiba Laptop NB100 and the system hangs during boot.
But if I boot the system in text mode, it loads OK. Then I write "startx" from console and I have gnome working. I have a different mouse cursor but everything seems to work.
The same error when I try to boot from Live Image into a USB disk created in Windows. I can boot perfectly from this image if I create it from a linux box (with live-cd-iso-to-disk).
Comment 16 Milos Jakubicek 2009-12-15 18:51:07 EST
Same problem with Intel 4500 graphics here. I don't know whether it is related but I use kdm and first time I try login into the system, it bounces back to the kdm login, the second try works. In /var/log/messages I see then:

Dec 15 23:40:28 localhost kernel: [drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
Dec 15 23:40:36 localhost kdm: :0[1423]: Cannot open ConsoleKit session: Unable to open session: Launch helper exited with unknown return code 0
Dec 15 23:40:36 localhost kdm: :0[1423]: Client start failed
Dec 15 23:40:36 localhost kdm: :0[1423]: Cannot close ConsoleKit session: Unable to close session: no session open
Comment 17 Jason Scalia 2009-12-17 23:07:51 EST
I am experiencing the same issue with Intel GMA 950 video and Intel 945GC north bridge (MSI Wind pc). I experienced this with a regular install of Fedora 12 i686 along with a new install fully patched. I was also able to replicate this in Ubuntu Karmic Koala, so I do not believe it is limited to Fedora.
Comment 18 work.webmail 2009-12-20 18:44:10 EST
I can confirm I have the same problem trying to install Fedora 12 (KDE, XFCE etc) via USB created by Unetbootin. I am trying to install it on both a Dell Inspiron 2200 and an Acer Aspire One (A0A-150).



The error I get is:

[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own

Boot has failed, sleeping forever




However, Fedora 11 works just fine with no issues at all. Argh!
Comment 19 Thomas Ramapuram 2009-12-22 00:15:56 EST
I have the problem in fC 12 when my kernel was updated from 

2.6.31.5-127.fc12.i686.PAE 

to 

2.6.31.6-166.fc12.i686.PAE

I cannot boot with the new kernel I have to keep selecting the old kernel from grub.  The error I get is 

[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own

Boot has failed, sleeping forever
Comment 20 Orion Poplawski 2009-12-22 11:27:43 EST
Those of you who cannot boot, edit the boot command line and remove rhgb and quiet from the options and see if the fb message is truly the last error.  For me, it appears to cause no problems at all, am I'm suspicious that something else is causing the boot failures.
Comment 21 Marie Henri Beyle 2009-12-23 06:12:18 EST
If you remove rhgb from kernel options, the system has no errors at boot time.
If you boot the system in text mode, it boots perfectly without errors.

There is something related to graphics module or screen boot that is interfering with a clean/standard boot.
Comment 22 Marie Henri Beyle 2009-12-23 06:13:44 EST
*** Bug 547288 has been marked as a duplicate of this bug. ***
Comment 23 neo8307 2009-12-25 03:51:00 EST
I had installed FC12 on 5th-dec. It worked fine till 21st and then suddenly it stopped responding after a reboot.
the error is the same as above..

[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own.

Booting has failed, sleeping forever.

after reading the posts here I tried rebooting in text mode (init level 3) but no luck. I got the following error message..

No root device found.

Boot has failed, sleeping forever.

I also tried some of the live cds (BackTrack 3) to get into the partitions and save my data (this the least I could do). But this also didn't work. The partitions is not responding to any of the other distros and fedora 12 dvd rescue mode itself.

although I am not a expert to advice something on this. but the way I look into the problem I would guess that the file table that exist inside the kernal is not accessible. because of which none of the other distro's are getting inside that partition including fedora 12 rescue mode.
Comment 24 neo8307 2009-12-26 09:00:03 EST
I have tried to mount the linux file system in rescue mood of FC12, as it was not recognising the linux partition automatically.

after few attempts and looking at the dmesg | tail I realize that my FS is EXT4 instead of EXT3 which I had given while installing.

I did a successful manual install with the given arguments and saved my data.

on the next boot I realised that FC12 rescue mode recognised the linux partition and mounted it automatically.

now my system is booting/working with no problem at all.
Comment 25 Orion Poplawski 2009-12-26 10:39:05 EST
Please move boot/root fs issues to another bug - this bug is for the drm message.
Comment 26 neo8307 2009-12-26 11:22:33 EST
sorry for the misunderstanding Orion.

I have quoted the problem in comment #23.

I wrote comment #24 to inform about the solution I got to the drm problem occurred on my notebook.

although its not exactly the solution.
Comment 27 Jason Taylor 2009-12-29 11:12:00 EST
TWO USB DRIVES - TWO RESULTS

If using a USB SanDisk cruzer colours+ 4GB ERROR
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own

Boot has failed, sleeping forever


If using USB LEXAR 33110-16GBA-1609 16GB - NO FAULT BOOT SUCCESS..

Both built using the same machine and image.

Repeatable using multiple desktops - DELL, NEC, IBM
Comment 28 Sergei LITVINENKO 2010-01-03 09:54:29 EST
On eee-901 have error in dmesg
---
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
---

System boot and work OK.

[root@eee901 ~]# uname -r
2.6.31.9-174.fc12.i686


[root@eee901 ~]# cat /boot/grub/grub.conf
---
...
default=0
timeout=3
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
# hiddenmenu
title Fedora (2.6.31.9-174.fc12.i686)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.31.9-174.fc12.i686 ro root=UUID=935bd116-c78e-455b-9f09-f68cc862fdea rhgb quiet LANG=ru_RU.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rd_plytheme=charge elevator=noop
        initrd /boot/initramfs-2.6.31.9-174.fc12.i686.img


[root@eee901 ~]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
04:00.0 Ethernet controller: Attansic Technology Corp. Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller (rev b0)
Comment 29 Carlos Correz 2010-01-03 12:10:08 EST
just a note, I experienced this bug when creating a live usb drive with several spins of Fedora 12. 

What solved the issue for me was unmounting the flash drive before rebooting or removing the drive for use with a different machine.
Comment 30 Thomas Ramapuram 2010-01-03 22:42:51 EST
(In reply to comment #19)
> I have the problem in fC 12 when my kernel was updated from 
> 
> 2.6.31.5-127.fc12.i686.PAE 
> 
> to 
> 
> 2.6.31.6-166.fc12.i686.PAE
> 
> I cannot boot with the new kernel I have to keep selecting the old kernel from
> grub.  The error I get is 
> 
> [drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
> 
> Boot has failed, sleeping forever  

Sorry about the wrong information.  Actually I had not set up raid on root(/) properly.  The new kernel tried to load the raid device but failed thereby throwing up this error.  It started working when I fixed the RAID issue.
Comment 31 Marie Henri Beyle 2010-01-04 07:03:31 EST
I have made an update last night that installs kernel-2.6.31.9-174 and another packages.
Now I can boot the system with rhgb kernel option activated and drm error has disappeared. I have booted the system with an older kernel and with rhgb option and the error has been removed.
So I keep on believing that the error is caused by something that loads with the graphic system, not the kernel because I could boot the system in text mode without problems. I could execute gnome from level 3 or I could write "init 5" without problems.
Unfortunately, the update installed 240 different packages and I don't know wich of them resolved the issue. If there is someone interested in the yum log, I can attach it in this bug.
Comment 32 Orion Poplawski 2010-01-04 12:26:52 EST
Still present for me with latest updates-testing including 2.6.31.9-174.fc12.x86_64.
Comment 33 Lee Heath 2010-01-05 12:48:08 EST
After removing the quiet I found that the error was misleading.  The error of trying to remove the fb was not related to the boot error.  My error was an unrecognized USB device after initial boot.  Once I changed to another device my system was able to boot fine, but still had the same frame buffer error.

I am not sure how many of these are specifically related to the FB error, or just the last error seen in the "graphical" boot mode.

Tanks to Orion at comment #20 for that suggestion.
Comment 34 FSW 2010-01-07 06:46:55 EST
I can see it here too, as well as the RH-bug 547599:

[fsw@hubble ~]$ dmesg |grep ERROR
[drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-D
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own

but everything is working fine: bootsplash, correct screen size & refresh rate (1366x768@60Hz), playing YouTube videos or DVD, TV through ADSL and even with 3D effects enabled (by the way, one of the painless installation ever, no hand configuration 'till now...)!

And I've never had the boot problem that some have described before...

The box is a Fujitsu-Siemens Amilo Li 3710 laptop, with almost everything Intel inside, apart from LAN & WLAN from Realtek.
	
[fsw@hubble ~]$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

[fsw@hubble ~]$ lsusb
Bus 002 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 09da:0006 A4 Tech Co., Ltd Optical Mouse WOP-35 / Trust 450L Optical Mouse
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

[fsw@hubble ~]$ uname -r
2.6.31.9-174.fc12.x86_64

[fsw@hubble ~]$ dmesg |head
Initializing cgroup subsys cpuset
Initializing cgroup subsys cpu
Linux version 2.6.31.9-174.fc12.x86_64 (mockbuild@x86-01.phx2.fedoraproject.org) (gcc version 4.4.2 20091027 (Red Hat 4.4.2-7) (GCC) ) #1 SMP Mon Dec 21 05:33:33 UTC 2009
Command line: ro root=UUID=058f0935-56b9-4868-a181-217067b91ada noiswmd LANG=fr_FR.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=fr rhgb quiet

So, it looks with my box more a cosmetic than a real issue, but I might be wrong...
Comment 35 FSW 2010-01-07 07:38:49 EST
Just to be exact, I've read too fast, I've also only a small part of the RH-bug 547599 (the i2c error message), not the whole problem, as it is far more annoying than that...

And I forgot to mention that I've installed Fedora 12 from the x86_64 Gnome Live-CD, if it's perhaps useful to know...
Comment 36 p000q 2010-01-11 02:05:37 EST
Same problem when I boot fedora 12 from a  USB stick created by UltraISO.
I've solved it.
This because fedora Live CD use CDLABEL to define root,but when we boot from USB, it change.
Edit "/syslinux/syslinux.cfg" and change the command: 
"append initrd=initrd0.img root=live:CDLABEL=Fedora-12-i686-Live" into
"append initrd=initrd0.img root=live:UUID=4471-9093" for USB HDD,
or change to
"append initrd=initrd0.img root=live:UUID=B4FE-5315" for USB ZIP.
Comment 37 FSW 2010-01-22 06:00:21 EST
As said in Comment 21 if I boot without the rhgb kernel parameter,
the fb error message disappears, so it really looks like being related to graphical boot:

[fsw@hubble ~]$ dmesg |grep ERROR
[drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-D

[fsw@hubble ~]$ dmesg |grep fb
fb0: inteldrmfb frame buffer device

[fsw@hubble ~]$ uname -r
2.6.31.12-174.2.3.fc12.x86_64

But the i2c error is still there...
Comment 38 Daniel Case 2010-01-27 20:34:55 EST
Making it boot in Init mode 3 brings some weird errors, im using the x64_86 live CD. I get the same error as above, but before that i have: 

"according to mtab, /dev/mapper/live-rw is already mounted on /sysroot"

May, many times, then comes the error message and the system is sleeping forever, then i get some I/O errors on device sr0, logical blocks and sectors ranging between 8620-8630.

Hope this helps
Comment 39 Daniel Case 2010-01-27 20:38:50 EST
I forgot to mention that im running a Fujitsu Siemens V6535, with the following processor:

*-cpu
          product: Intel(R) Pentium(R) Dual  CPU  T3400  @ 2.16GHz
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          size: 1GHz
          capacity: 1GHz
          width: 64 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx x86-64 constant_tsc arch_perfmon pebs bts rep_good pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm cpufreq

And for the people who have mentioned it could be a graphics issue, im running the following:

*-display:0
             description: VGA compatible controller
             product: Mobile 4 Series Chipset Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 07
             width: 64 bits
             clock: 33MHz
             capabilities: bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:30 memory:f2400000-f27fffff memory:d0000000-dfffffff(prefetchable) ioport:1800(size=8)
Comment 40 Robert de Rooy 2010-02-16 09:12:51 EST
Still happens with kernel-2.6.32.8-48.rc2.fc12.x86_64 on a ThinkPad T60 with i945GM

Also it happens once for each attached display, so with a dual display setup I get it twice.
Comment 41 Yaniv Kaul 2010-03-07 02:00:40 EST
[ykaul@ykaul ~]$ dmesg |grep drm
[drm] Initialized drm 1.1.0 20060810
[drm] set up 31M of stolen space
fbcon: inteldrmfb (fb0) is primary device
fb0: inteldrmfb frame buffer device
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:i915_gem_madvise_ioctl] *ERROR* Attempted i915_gem_madvise_ioctl() on a pinned object

[ykaul@ykaul ~]$ uname -r
2.6.32.9-67.fc12.x86_64

Lenovo T500,
Comment 42 Jaroslav Franek 2010-03-27 08:41:22 EDT
Also happens with Fedora 13 Alpha, Radeon 9000 (RV250), KMS, rhgb,
kernel-2.6.33-1.fc13.i686

[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
Comment 43 Ben Woodard 2010-03-29 23:11:21 EDT
The problem doesn't seem to happen with 2.6.32-19.el6 on the RHEL6 almost beta. On a Lenovo X301
Comment 44 Ben Woodard 2010-03-30 00:14:49 EDT
Also the Fedora 11 live CD also doesn't have the problem
Comment 45 Oiki Yukio 2010-03-30 16:22:30 EDT
This also happens to me (Fedora 13 Alpha) with 2.6.33.1-19.fc13.x86_64
Comment 46 Salman Ullah Baig 2010-03-30 18:52:13 EDT
I conform this bug on fedora 12 live CD installation.
Comment 47 Blaz Pristy 2010-04-06 05:03:14 EDT
Yep same here, no can do...can't boot this thing, next time test on some different machines before release how hard is that. Maybe is UNetbootin problem, it adds some more option for boot then Fedora it self after creating, boot from ISO works in Vbox but not from USB key. Maybe is this EFI problem i don't know that you use it, i have MSI G31 board.
Comment 48 Joey Boggs 2010-05-11 13:27:47 EDT
*** Bug 533156 has been marked as a duplicate of this bug. ***
Comment 49 Blaz Pristy 2010-05-11 14:14:01 EDT
It's fixed on Fedora 13!
Comment 50 Andrew Grzegorek 2010-05-25 16:41:50 EDT
(In reply to comment #36)
> Same problem when I boot fedora 12 from a  USB stick created by UltraISO.
> I've solved it.
> This because fedora Live CD use CDLABEL to define root,but when we boot from
> USB, it change.
> Edit "/syslinux/syslinux.cfg" and change the command: 
> "append initrd=initrd0.img root=live:CDLABEL=Fedora-12-i686-Live" into
> "append initrd=initrd0.img root=live:UUID=4471-9093" for USB HDD,
> or change to
> "append initrd=initrd0.img root=live:UUID=B4FE-5315" for USB ZIP.    

(In reply to comment #36)
My Fedora12 live on USB stick would hang during booting because of wrong UUID value in "/syslinux/syslinux.cfg". 
To get correct UUID do:
sudo /lib/udev/vol_id --uuid /dev/sdc1 # Use your USB stick device name

After syslinux.cfg edit it boots fine but I still have problem with persistent changes. All changes are gone after a reboot.
Comment 51 FSW 2010-06-09 17:32:22 EDT
Fedora 13 solved it all here also!
Now it looks great (again):

[fsw@hubble ~]$ uname -r
2.6.33.5-112.fc13.x86_64

[fsw@hubble ~]$ dmesg |grep ERROR

[fsw@hubble ~]$ dmesg |grep i2c

[fsw@hubble ~]$ dmesg |grep fb
fbcon: inteldrmfb (fb0) is primary device
fb0: inteldrmfb frame buffer device

[fsw@hubble ~]$ dmesg |grep drm
[drm] Initialized drm 1.1.0 20060810
[drm] set up 127M of stolen space
fbcon: inteldrmfb (fb0) is primary device
fb0: inteldrmfb frame buffer device
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0

But I can't say if there was ever some similar troubles with USB in my case, as I only booted Fedora 12 & 13 on Live-CD than installed both on HDD...
Comment 52 Robert de Rooy 2010-07-07 05:50:20 EDT
I think this can be closed as solved in current release based on various confirmations.
Comment 53 Fernando 2010-07-24 18:24:54 EDT
I have this same error.

Fedora 12
Kernel: 2.6.32.16-141.fc12.i686)

lspci -v | grep VGA:
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 01) (prog-if 00 [VGA controller])

Message in boot:
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id

Note You need to log in before you can comment on or make changes to this bug.