Bug 539764 - KMS::MESA Bad cmd stream (OpenGL applications)
Summary: KMS::MESA Bad cmd stream (OpenGL applications)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-21 00:39 UTC by trevor
Modified: 2018-04-11 17:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-31 10:24:17 UTC
Type: ---


Attachments (Terms of Use)
Output of dmesg (40.44 KB, text/plain)
2010-03-08 08:04 UTC, trevor
no flags Details
/var/log/messages (71.71 KB, text/plain)
2010-03-08 08:10 UTC, trevor
no flags Details
Xorg.0.log (61.35 KB, text/plain)
2010-03-08 08:12 UTC, trevor
no flags Details
dmesg output after upgrade to 2.6.32.9-67.fc12.i686 (41.37 KB, text/plain)
2010-03-08 08:42 UTC, trevor
no flags Details
/var/log/messages after upgrade to 2.6.32.9-67.fc12.i686 (147.48 KB, text/plain)
2010-03-08 08:49 UTC, trevor
no flags Details
Xorg.0.log after upgrade to 2.6.32.9-67.fc12.i686 (62.52 KB, text/plain)
2010-03-08 08:51 UTC, trevor
no flags Details

Description trevor 2009-11-21 00:39:42 UTC
Description of problem: Eclipse RCP based Java program, Kelpie Flight Planner for flightgear crashes on startup with error:
drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.

dmesg contains the following:
[drm:r100_cs_track_check] *ERROR* [drm] No buffer for z buffer !
[drm:radeon_cs_ioctl] *ERROR* Invalid command stream !


Version-Release number of selected component (if applicable):
Name       : xorg-x11-drv-ati
Arch       : i686
Version    : 6.13.0
Release    : 0.10.20091006git457646d73.fc12


How reproducible:
Always happens

Steps to Reproduce:
1. Download and install Kelpie Flight Planner for Flightgear from http://sourceforge.net/projects/fgflightplanner/
2. Unpack application
3. Run application >   ./kelpie-planner

Actual results:
Appplication crashes

Expected results:
Application does not crash

Additional info: This application uses OpenGL and currently runs on earlier version of the xorg-x11-drv-ati driver, but the Open GL behavior is rubbish on the earlier drivers.

Comment 1 trevor 2009-11-21 01:20:32 UTC
Turnong off mode setting (kernel option nomodeset) fixes this issue.  All the OpenGL behaviour then becomes very dodgy, especially unger Compiz.

Comment 2 Jérôme Glisse 2009-11-24 19:14:28 UTC
Likely duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=540133

Comment 3 Jérôme Glisse 2010-01-13 18:05:36 UTC
It should be fixed if you update fedora 12 (yum update or through the graphical interface). Please report your result.

Comment 4 trevor 2010-01-14 10:38:21 UTC
Sorry to say, I still have the same error.

I did "yum update" and also a shutdown and restarted computer.

dmesg says
[drm:r100_cs_track_check] *ERROR* [drm] No buffer for z buffer !
[drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

Comment 5 Jason Ihrke 2010-02-26 22:23:38 UTC
I'm getting the same error trying to run X-Plane 9.4 on Fedora 12.

Comment 6 Matěj Cepl 2010-03-04 14:11:55 UTC
(In reply to comment #4)
> Sorry to say, I still have the same error.
> 
> I did "yum update" and also a shutdown and restarted computer.
> 
> dmesg says
> [drm:r100_cs_track_check] *ERROR* [drm] No buffer for z buffer !
> [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !    

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, system log (/var/log/messages), and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 7 trevor 2010-03-08 08:04:40 UTC
Created attachment 398479 [details]
Output of dmesg

Comment 8 trevor 2010-03-08 08:10:11 UTC
Created attachment 398481 [details]
/var/log/messages

Comment 9 trevor 2010-03-08 08:12:49 UTC
Created attachment 398482 [details]
Xorg.0.log

I am not using a /etc/X11/xorg.conf

Comment 10 trevor 2010-03-08 08:42:34 UTC
Created attachment 398483 [details]
dmesg output after upgrade to 2.6.32.9-67.fc12.i686

I just got a normal set of updates awhich included a new kernel - 2.6.32.9-67.fc12.i686.  Retested and these are the files after that.

Comment 11 trevor 2010-03-08 08:49:56 UTC
Created attachment 398484 [details]
/var/log/messages after upgrade to 2.6.32.9-67.fc12.i686

Comment 12 trevor 2010-03-08 08:51:54 UTC
Created attachment 398485 [details]
Xorg.0.log after upgrade to 2.6.32.9-67.fc12.i686

Comment 13 trevor 2010-08-29 07:23:19 UTC
This is now fixed for me after upgrade to xorg-x11-drv-ati
Version information is :

$ yum info xorg-x11-drv-ati
Loaded plugins: presto, priorities, refresh-packagekit
Installed Packages
Name        : xorg-x11-drv-ati
Arch        : i686
Version     : 6.13.0
Release     : 1.fc13
Size        : 1.1 M
Repo        : installed
From repo   : anaconda-InstallationRepo-201005130056.i386
Summary     : Xorg X11 ati video driver
URL         : http://www.x.org
License     : MIT
Description : X.Org X11 ati video driver.

Comment 14 Matěj Cepl 2010-08-31 10:24:17 UTC
Thank you for letting us know.


Note You need to log in before you can comment on or make changes to this bug.