Bug 539785 - X misidentifies monitor, prevents selection of many resolutions
X misidentifies monitor, prevents selection of many resolutions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-20 21:51 EST by Joel Uckelman
Modified: 2010-05-24 14:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-06 13:18:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from the last boot to F11, monitor detected properly (102.04 KB, text/plain)
2009-11-20 21:51 EST, Joel Uckelman
no flags Details
log from F12, monitor not properly detected (262.34 KB, text/plain)
2009-11-20 21:53 EST, Joel Uckelman
no flags Details
dmesg from F12 (67.62 KB, text/plain)
2009-11-20 21:54 EST, Joel Uckelman
no flags Details

  None (edit)
Description Joel Uckelman 2009-11-20 21:51:10 EST
Created attachment 372668 [details]
log from the last boot to F11, monitor detected properly

Description of problem:

After upgrading from F11 to F12, the external monitor attached to my laptop dock is no longer detected properly, and no resolutions above 1280x1024 are available, despite that this monitor is capable of 1600x1200. This is quite annoying.


Version-Release number of selected component (if applicable):

2.9.1-1.fc12


How reproducible:

Always.

Steps to Reproduce:
1. Boot with the laptop docked.
2. Log in to X.
  
Actual results:

Modes above 1280x1024 are rejected by the X server, and the monitor runs in 1280x1024.

Expected results:

1600x1200 should be selectable from "System > Preferences > Display" in GNOME,
and after selecting that the monitor should run in 1600x1200, as it used to in F11.

Additional info:

The monitor is a Sony Multiscan CPD-G520. The laptop is a Lenovo Thinkpad T61.
Comment 1 Joel Uckelman 2009-11-20 21:53:41 EST
Created attachment 372669 [details]
log from F12, monitor not properly detected
Comment 2 Joel Uckelman 2009-11-20 21:54:54 EST
Created attachment 372670 [details]
dmesg from F12
Comment 3 Joel Uckelman 2009-12-02 07:27:38 EST
I've tried creating an xorg.conf containing the modeline used by X as indicated in the F11 xorg.0.log. This also fails. There seems to be no way to convince the new version of X to run my monitor at more than 1280x1024.
Comment 4 Chris Campbell 2009-12-03 13:18:52 EST
Looks like all required logs are aboard, setting keyword triaged and status to assigned.

This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Joel Uckelman 2010-01-09 14:52:25 EST
I've discovered that I can use xrandr to force X to run my monitor with the modeline I used in F11:

xrandr --newmode "1600x1200"x75.0  202.50  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync
xrandr --addmode VGA1 "1600x1200"x75.0
xrandr --output VGA1 --mode 1600x1200x75.0

This mitigates the problem for me a little, but it still should be looked into that the monitor isn't properly detected.
Comment 6 Joel Uckelman 2010-01-09 15:07:38 EST
(In reply to comment #5)
> I've discovered that I can use xrandr to force X to run my monitor with the
> modeline I used in F11:
> 

Of course, doing this causes the gnome-panel to vanish, despite that it still claims to be running, and it isn't sticky---I now have to do this every time I log in.

If there's anything I can contribute to getting this problem resolved, please don't hesitate to let me know.
Comment 7 Henrique Martins 2010-02-16 10:12:15 EST
If you can do it with xrandr you should be able to do it with xorg.conf. Read this page http://www.thinkwiki.org/wiki/Xorg_RandR_1.2 for a reasonable good guide.
Comment 8 Adam Jackson 2010-02-16 13:11:04 EST
This should be fixed by this kernel change upstream:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=07a5e6324abacad56a8e7bcb44dd404e84f75f57

which is present in at least kernel-2.6.31.12-174.2.19.fc12 and later.
Comment 9 Joel Uckelman 2010-02-23 13:54:13 EST
This is not fixed. I'm running 2.6.31.12-174.2.22.fc12.x86_64 right now, and my monitor is still misidentified.
Comment 10 Pete Gale 2010-03-06 04:28:26 EST
I have a very similar problem on a Dell Latitude E6400 (Intel Corporation Mobile 4 Series Chipset, using the xorg-x11-drv-intel-2.9.1-1.fc12.x86_64 driver).

If I boot up undocked, then it's fine.

If docked, then it puts my panels on my laptop screen and a blank screen on the monitor. When I either open my laptop display or touch the GNOME "System > Preferences > Display", then I get 1024x768 on both laptop and monitor.

If I run this script, then I get the right size for my monitor with panels and all.

#!/bin/sh
xrandr --output LVDS1 --mode 1440x900
xrandr --output VGA1  --mode 1920x1080

I'll give the guide above a try. The laptop worked fine until I upgraded to FC12 from FC11, however.
Comment 11 Joel Uckelman 2010-03-12 19:26:42 EST
With kernel 2.6.32.9-70.fc12.x86_64, my monitor is now correctly identified.
Comment 12 Pete Gale 2010-03-15 17:13:28 EDT
This issue is now a "works-for-me", after upgrading to kernel-2.6.32.9-70.fc12.x86_64 and removing "nomodeset" from Grub. Just in case the rest of the Grub kernel line matters, it is:

    kernel /boot/vmlinuz-2.6.32.9-70.fc12.x86_64 ro root=UUID=<removed> rhgb video=intelfb:mode=1440x900-32@70,mtrr=1 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us intel_tv_mode_set=off enable_mtrr_cleanup mtrr_chunk_size=128M mtrr_gran_size=128M
Comment 13 Adam Jackson 2010-04-06 13:18:42 EDT
Marking closed per the last two comments.
Comment 14 Pete Gale 2010-05-24 14:24:37 EDT
I just upgraded to Fedora 13 (kernel 2.6.33.4-95.fc13.x86_64) and this exact problem is back. Whatever change was made in kernel-2.6.32.9-70.fc12.x86_64 to get rid of this problem did not make it to this kernel. The grub settings are the same.

Note You need to log in before you can comment on or make changes to this bug.