Bug 539789 - [abrt] crash detected in compiz-0.8.2-19.fc12 -- Arithmetic exception -- #0 in intel_miptree_pitch_align at intel_mipmap_tree.c:255 (By activating Desktop effects)
Summary: [abrt] crash detected in compiz-0.8.2-19.fc12 -- Arithmetic exception -- #0 i...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:10a8b98985edf2e62a67d91827b...
: 540256 540423 540682 541578 541650 542470 543796 544627 544969 545541 548878 548899 550609 550980 551008 551634 551734 554565 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-21 03:13 UTC by arbitrabbit
Modified: 2010-02-15 11:48 UTC (History)
25 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-15 11:48:37 UTC


Attachments (Terms of Use)
File: backtrace (20.93 KB, text/plain)
2009-11-21 03:13 UTC, arbitrabbit
no flags Details
Xorg.conf file (2.24 KB, text/plain)
2009-11-22 18:07 UTC, Martin Schneider
no flags Details
dmesg comand output (48.62 KB, text/plain)
2009-11-22 18:10 UTC, Martin Schneider
no flags Details
Xorg.0.log (40.57 KB, text/plain)
2009-11-22 18:12 UTC, Martin Schneider
no flags Details
backtrace captured by abrt (22.04 KB, text/plain)
2009-11-24 22:32 UTC, Robinson Maureira
no flags Details
Xorg log of the current session (44.03 KB, text/plain)
2009-11-24 22:33 UTC, Robinson Maureira
no flags Details
dmesg of the current session (45.15 KB, text/plain)
2009-11-24 22:33 UTC, Robinson Maureira
no flags Details

Description arbitrabbit 2009-11-21 03:13:55 UTC
abrt detected a crash.

Comment: Just started compiz
Attached file: backtrace
cmdline: compiz --ignore-desktop-hints glib gconf gnomecompat --replace
component: compiz
executable: /usr/bin/compiz
kernel: 2.6.31.5-127.fc12.i686
package: compiz-0.8.2-19.fc12
rating: 4
reason: Process was terminated by signal 8

Comment 1 arbitrabbit 2009-11-21 03:13:58 UTC
Created attachment 372673 [details]
File: backtrace

Comment 2 Hamidou Dia 2009-11-22 03:15:12 UTC
Dear reporter.

Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Regards

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Martin Schneider 2009-11-22 18:07:54 UTC
Created attachment 372939 [details]
Xorg.conf file

Comment 4 Martin Schneider 2009-11-22 18:10:10 UTC
Created attachment 372940 [details]
dmesg comand output

Comment 5 Martin Schneider 2009-11-22 18:12:02 UTC
Created attachment 372941 [details]
Xorg.0.log

Comment 6 Hamidou Dia 2009-11-22 23:29:15 UTC
Hi Martin,

Many thanks again for this information.

This bug has been triaged.

Regards

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Hamidou Dia 2009-11-22 23:32:28 UTC
*** Bug 540256 has been marked as a duplicate of this bug. ***

Comment 8 Hamidou Dia 2009-11-24 02:33:27 UTC
Putting BZ#540682 as duplicate : Note that it looks like this crash is triggered by activating "Desktop Effects" (as per comment https://bugzilla.redhat.com/show_bug.cgi?id=540682#c8 ).

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 9 Hamidou Dia 2009-11-24 02:34:34 UTC
*** Bug 540682 has been marked as a duplicate of this bug. ***

Comment 10 Adel Gadllah 2009-11-24 21:51:15 UTC
Hi,

Are you able to reproduce this bug?

If yes how?

It looks like a driver bug to me, but I cannot reproduce it here (even thought I am using a GM45 too).

Comment 11 Robinson Maureira 2009-11-24 22:31:08 UTC
OK, here are the versions and steps to reproduce it.

1.- boot kernel with nomodeset and intel_iommu=off
2.- Go to System -> Preferences -> Desktop Effects
3.- Enable Compiz

xorg-x11-server-Xorg-1.7.1-9.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64
compiz-0.8.2-19.fc12.x86_64
kernel-2.6.31.6-148.fc12.x86_64
mesa-dri-drivers-7.6-0.15.fc12.i686

$ lspci -n
00:00.0 0600: 8086:2a40 (rev 07)
00:02.0 0300: 8086:2a42 (rev 07)
00:02.1 0380: 8086:2a43 (rev 07)
00:1a.0 0c03: 8086:2937 (rev 03)
00:1a.1 0c03: 8086:2938 (rev 03)
00:1a.2 0c03: 8086:2939 (rev 03)
00:1a.7 0c03: 8086:293c (rev 03)
00:1b.0 0403: 8086:293e (rev 03)
00:1c.0 0604: 8086:2940 (rev 03)
00:1c.1 0604: 8086:2942 (rev 03)
00:1c.2 0604: 8086:2944 (rev 03)
00:1c.4 0604: 8086:2948 (rev 03)
00:1c.5 0604: 8086:294a (rev 03)
00:1d.0 0c03: 8086:2934 (rev 03)
00:1d.1 0c03: 8086:2935 (rev 03)
00:1d.2 0c03: 8086:2936 (rev 03)
00:1d.7 0c03: 8086:293a (rev 03)
00:1e.0 0604: 8086:2448 (rev 93)
00:1f.0 0601: 8086:2919 (rev 03)
00:1f.2 0106: 8086:2929 (rev 03)
02:00.0 0280: 8086:4237
85:00.0 0200: 14e4:1693 (rev 02)
86:02.0 0c00: 11c1:5811 (rev 70)

$ lspci 
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
02:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
85:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
86:02.0 FireWire (IEEE 1394): Agere Systems FW322/323 (rev 70)

I'll attach the backtrace captured by abrt, and Xorg.* files, along with dmesg...

Comment 12 Robinson Maureira 2009-11-24 22:32:17 UTC
Created attachment 373563 [details]
backtrace captured by abrt

Comment 13 Robinson Maureira 2009-11-24 22:33:01 UTC
Created attachment 373564 [details]
Xorg log of the current session

Comment 14 Robinson Maureira 2009-11-24 22:33:24 UTC
Created attachment 373565 [details]
dmesg of the current session

Comment 15 Hamidou Dia 2009-11-25 17:58:25 UTC
Hi Adel,

The howto trigger was already mention in https://bugzilla.redhat.com/show_bug.cgi?id=539789#c8 and the title ;-)

Robinson confirmed it again.

So I am clearing the needinfo flag.

Regards.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 16 Hamidou Dia 2009-11-25 17:59:58 UTC
PS: this one as well looks like a driver/mesa bug (put in evidence by compiz).

Comment 17 Robinson Maureira 2009-11-25 18:03:37 UTC
On another BZ someone suggested to use compiz-fusion, and the crash was worst, it crashed X, so yeah, I guess is driver related too...

Comment 18 Hamidou Dia 2009-11-26 19:26:04 UTC
*** Bug 541578 has been marked as a duplicate of this bug. ***

Comment 19 Hamidou Dia 2009-11-26 22:04:51 UTC
*** Bug 541650 has been marked as a duplicate of this bug. ***

Comment 20 Hamidou Dia 2009-11-30 03:11:20 UTC
*** Bug 542470 has been marked as a duplicate of this bug. ***

Comment 21 Hamidou Dia 2009-12-03 19:10:19 UTC
So I can search it faster next time:

Core was generated by `compiz --ignore-desktop-hints glib gconf gnomecompat --replace'.
Program terminated with signal 8, Arithmetic exception.
#0  0x0042bb68 in intel_miptree_pitch_align (intel=0x8ef59f0, mt=0x92ad300, 
    tiling=1, pitch=<value optimized out>) at intel_mipmap_tree.c:255
	in intel_mipmap_tree.c

Thread 1 (Thread 10813):
#0  0x0042bb68 in intel_miptree_pitch_align (intel=0x8ef59f0, mt=0x92ad300, 
    tiling=1, pitch=<value optimized out>) at intel_mipmap_tree.c:255
        pitch_align = 512
#1  0x00443ca6 in i945_miptree_layout_2d (intel=<value optimized out>, 
    mt=<value optimized out>, tiling=<value optimized out>)
    at intel_tex_layout.c:108
        align_h = 2
        align_w = 4
        level = <value optimized out>
        x = 0
        y = 0
        width = <value optimized out>
        height = <value optimized out>


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers 


----------------------------------------------------------------

Because this is an F12 ticket, assigning as well.

Comment 22 Hamidou Dia 2009-12-03 19:12:34 UTC
*** Bug 543796 has been marked as a duplicate of this bug. ***

Comment 23 Hamidou Dia 2009-12-03 19:15:09 UTC
*** Bug 540423 has been marked as a duplicate of this bug. ***

Comment 24 Hamidou Dia 2009-12-07 08:39:54 UTC
*** Bug 544969 has been marked as a duplicate of this bug. ***

Comment 25 Hamidou Dia 2009-12-07 08:47:48 UTC
*** Bug 544627 has been marked as a duplicate of this bug. ***

Comment 26 Adam Williamson 2009-12-11 20:54:24 UTC
Just a note - I mentioned this bug to ajax at FUDCon, he says he's aware of it and will get around to taking a look at it soon. I think he may be on vacation soon though too.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 27 Adel Gadllah 2009-12-12 23:38:20 UTC
*** Bug 545541 has been marked as a duplicate of this bug. ***

Comment 28 Hamidou Dia 2009-12-24 13:53:44 UTC
*** Bug 548899 has been marked as a duplicate of this bug. ***

Comment 29 Hamidou Dia 2009-12-24 13:55:55 UTC
*** Bug 548878 has been marked as a duplicate of this bug. ***

Comment 30 Adel Gadllah 2009-12-26 17:05:49 UTC
*** Bug 550609 has been marked as a duplicate of this bug. ***

Comment 31 Adel Gadllah 2009-12-28 13:24:45 UTC
*** Bug 550980 has been marked as a duplicate of this bug. ***

Comment 32 Adel Gadllah 2009-12-28 14:22:29 UTC
*** Bug 551008 has been marked as a duplicate of this bug. ***

Comment 33 Adel Gadllah 2009-12-31 22:11:20 UTC
*** Bug 551634 has been marked as a duplicate of this bug. ***

Comment 34 Adel Gadllah 2010-01-01 15:43:48 UTC
*** Bug 551734 has been marked as a duplicate of this bug. ***

Comment 35 Hamidou Dia 2010-01-12 08:38:28 UTC
*** Bug 554565 has been marked as a duplicate of this bug. ***

Comment 36 Felix Möller 2010-02-14 23:11:54 UTC
I think this has been fixed by some update. At least it does not happen to me anymore.

Comment 37 Theodore Lee 2010-02-15 10:54:13 UTC
Same here. A mesa update seems to have fixed this for me too.

Comment 38 Christian Kalkhoff 2010-02-15 11:01:31 UTC
I can confirm. Fixed by some update.

Comment 39 Adel Gadllah 2010-02-15 11:48:37 UTC
(In reply to comment #36)
> I think this has been fixed by some update. At least it does not happen to me
> anymore.    

(In reply to comment #37)
> Same here. A mesa update seems to have fixed this for me too.    

(In reply to comment #38)
> I can confirm. Fixed by some update.    

OK, thanks for confirming that ... the duplicates have stopped for a while so I assume this is indeed fixed.

Feel free to reopen if you can reproduce it.


Note You need to log in before you can comment on or make changes to this bug.