Bug 539848 - [abrt] crash detected in sound-juicer-2.28.0-4.fc12
Summary: [abrt] crash detected in sound-juicer-2.28.0-4.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sound-juicer
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:429e71424c258e23c5e10563fb0...
: 540889 542407 542408 542805 543830 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-21 10:46 UTC by Vesa Halttunen
Modified: 2009-12-05 00:03 UTC (History)
5 users (show)

Fixed In Version: 2.28.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-05 00:03:32 UTC


Attachments (Terms of Use)
File: backtrace (7.40 KB, text/plain)
2009-11-21 10:46 UTC, Vesa Halttunen
no flags Details

Description Vesa Halttunen 2009-11-21 10:46:21 UTC
abrt detected a crash.

Comment: I tried to rip a CD that either had a data track in addition to the audio track or had no details in musicbrainz or both. I'm not sure which one of these caused the crash. I assume it's the data track since Sound Juicer does not crash when the disc is mounted through the GNOME Places menu first. This problem is consistently reproducable with several CDs.
Attached file: backtrace
cmdline: sound-juicer
component: sound-juicer
executable: /usr/bin/sound-juicer
kernel: 2.6.31.5-127.fc12.i686.PAE
package: sound-juicer-2.28.0-4.fc12
rating: 4
reason: Process was terminated by signal 6

Comment 1 Vesa Halttunen 2009-11-21 10:46:24 UTC
Created attachment 372721 [details]
File: backtrace

Comment 2 Vesa Halttunen 2009-11-21 11:14:36 UTC
Actually I think it's more likely that it's the "disk details not found from musicbrainz" after all or a combination of these two since discs with a data track that are found from musicbrainz do not cause this problem.

Comment 3 Vesa Halttunen 2009-11-21 13:24:28 UTC
I can confirm that the crash occurs for every disc for which there is no MusicBrainz data. Data tracks do not affect the situation.

Comment 4 Bastien Nocera 2009-11-24 15:50:26 UTC
*** Bug 540889 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2009-11-25 16:17:03 UTC
sound-juicer-2.28.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/sound-juicer-2.28.1-1.fc12

Comment 6 Fedora Update System 2009-11-27 22:02:51 UTC
sound-juicer-2.28.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sound-juicer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12308

Comment 7 Bastien Nocera 2009-12-04 11:07:51 UTC
*** Bug 542407 has been marked as a duplicate of this bug. ***

Comment 8 Bastien Nocera 2009-12-04 11:08:04 UTC
*** Bug 542408 has been marked as a duplicate of this bug. ***

Comment 9 Bastien Nocera 2009-12-04 11:08:22 UTC
*** Bug 542805 has been marked as a duplicate of this bug. ***

Comment 10 Bastien Nocera 2009-12-04 11:10:30 UTC
*** Bug 543830 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2009-12-05 00:03:27 UTC
sound-juicer-2.28.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.