Bug 53986 - kernel source rpm pre-install scripts "fail" when they aren't failing
Summary: kernel source rpm pre-install scripts "fail" when they aren't failing
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-24 23:23 UTC by j. alan eldridge
Modified: 2015-01-04 22:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-30 03:42:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description j. alan eldridge 2001-09-24 23:23:36 UTC
Description of Problem:
The pre-install scripts for the headers do:

[ -L /usr/include/linux ] && rm -f /usr/include/linux
[ -L /usr/include/asm ] && rm -f /usr/include/asm

But if those aren't links, it's NOT a failure. But, since the result of the executions 
was false, rpm bitches and bags the install.

Make it:

[ -L /usr/include/linux ] && rm -f /usr/include/linux || true
[ -L /usr/include/asm ] && rm -f /usr/include/asm || true

and then this false-failure won't happen.

Comment 1 Arjan van de Ven 2001-09-25 07:37:10 UTC
I agree on the solution.

However, how did those headers get there ? And RPM will bitch if 
there are files with the same names there.....


Note You need to log in before you can comment on or make changes to this bug.