Bug 539936 - Regression in R300 KMS : switching to LVDS non native resolution results in lost sync
Regression in R300 KMS : switching to LVDS non native resolution results in l...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
card_R420/mM
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-21 12:13 EST by bernard.godard
Modified: 2010-01-31 16:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-31 16:41:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (32.50 KB, text/plain)
2009-11-21 12:14 EST, bernard.godard
no flags Details
/var/log/messages (361.30 KB, text/plain)
2009-11-21 12:14 EST, bernard.godard
no flags Details
glxinfo (15.56 KB, text/plain)
2009-11-21 12:15 EST, bernard.godard
no flags Details
xorg.log (59.62 KB, text/plain)
2009-11-21 12:16 EST, bernard.godard
no flags Details
xdpyinfo (17.19 KB, text/plain)
2009-11-21 12:17 EST, bernard.godard
no flags Details
xrandr -q (512 bytes, text/plain)
2009-11-21 12:18 EST, bernard.godard
no flags Details
lspci -vvvxxx (33.67 KB, text/plain)
2009-11-21 12:19 EST, bernard.godard
no flags Details

  None (edit)
Description bernard.godard 2009-11-21 12:13:36 EST
Description of problem:
Using Fedora 12 i686, with ATI Mobility Radeon X700, using KMS/DRI2, when switching to LVDS non native resolution, monitor shows only garbage.

Version-Release number of selected component (if applicable):
2.6.31.5-127.fc12.i686

How reproducible: always

Steps to Reproduce: switch resolution from LVDS native 1280x800 to anything else by using xrandr or by launching a game (supertuxkart, extremetuxracer, secret maryo chronicles) with lower resolution in fullscreen
  
Actual results:
garbage on screen
in 1152x768 : desktop can be seen but it is not synced so it is moving very fast.
in 1024x768 : screen is black except vertical white line on the left side 
in 800x600 : screen is made of vertical lines

It seems the monitor does not sync.
However, the system is still responding.
I can switch virtual terminals with Ctrl+Alt-Fn
I can take a screenshot with PrintScreen : Looking at the screenshot after resolution has been reset, it shows the desktop as it should be, so it doesn't seem the video memory is corrupted, but that the monitor cannot support the signal.



Expected results:
monitor does not show garbage but desktop or game.


Additional info:
Two months ago, I had Fedora rawhide on that same laptop with KMS/DRI2 enabled, and I don't remember having experienced any problems of this kind when playing extremetuxracer or secret maryo chronicles in fullscreen, so I think this is a regression.
Comment 1 bernard.godard 2009-11-21 12:14:18 EST
Created attachment 372764 [details]
dmesg
Comment 2 bernard.godard 2009-11-21 12:14:51 EST
Created attachment 372765 [details]
/var/log/messages
Comment 3 bernard.godard 2009-11-21 12:15:39 EST
Created attachment 372766 [details]
glxinfo
Comment 4 bernard.godard 2009-11-21 12:16:44 EST
Created attachment 372767 [details]
xorg.log
Comment 5 bernard.godard 2009-11-21 12:17:35 EST
Created attachment 372768 [details]
xdpyinfo
Comment 6 bernard.godard 2009-11-21 12:18:23 EST
Created attachment 372770 [details]
xrandr -q
Comment 7 bernard.godard 2009-11-21 12:19:15 EST
Created attachment 372771 [details]
lspci -vvvxxx
Comment 8 Robert de Rooy 2009-12-01 05:51:50 EST
I seem to be having the same problem on a ThinkPad T41 with RV250.

Lowering the LVDS resolution from its native 1400x1050 results in a black display with glowing white spots and some lines. This can be triggered by using mirror display with an external display at lower resolution, or as mentioned by starting something like extremetuxracer which lowers the resolution to 800x600.
Comment 9 bjaglin 2009-12-16 17:58:01 EST
Just tried on my T40p the latest drm-radeon-testing and ddx, and the problem is reproducable.

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility
FireGL 9000] (rev 02)

I can't reproduce the problem on a vanilla 2.6.31 since xrandr allows only the native resolution; etracer runs OK but occupies only part of the screen (the center).
Comment 10 bjaglin 2009-12-20 17:26:02 EST
This problem was partly addressed in a recent patch in drm-radeon-testing: http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=commit;h=161c7aba9b5fcf7c7d856c1b463bc61286beabcc

Non-native resolutions work fine for me now, both in aspect and in center "scaling mode", except 640x480 which works only in center: I get a black screen when using aspect. This is however not the same glowing+horizontal lines effect I had before the patch.
Comment 11 bernard.godard 2010-01-06 10:57:57 EST
changed component from kernel to xorg-x11-drv-ati as this seems more in line with other ATI bug reports even though this is KERNEL mode setting.
Comment 12 Robert de Rooy 2010-01-13 04:22:36 EST
This issue is solved for me with kernel-2.6.32.3-24.fc12.i686 from Koji
http://koji.fedoraproject.org/koji/buildinfo?buildID=150696
Comment 13 bernard.godard 2010-01-16 12:44:13 EST
At the moment, I am running on same hardware FC12 64 bits version + updates
from testing and kernel-2.6.32.3-24.fc12.x86_64 from Koji
http://koji.fedoraproject.org/koji/buildinfo?buildID=150696 with dependencies
and the problem seems solved.
Comment 14 Matěj Cepl 2010-01-31 16:41:11 EST
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.