Bug 539975 - corrupted display under KMS with nouveau
Summary: corrupted display under KMS with nouveau
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-21 20:06 UTC by Jaroslav Franek
Modified: 2010-06-03 17:37 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-06-03 17:37:26 UTC


Attachments (Terms of Use)
dmesg under User Mode Settings (43.51 KB, application/octet-stream)
2009-12-01 08:58 UTC, Jaroslav Franek
no flags Details
dmesg under Kernel Mode Setting (45.81 KB, application/octet-stream)
2009-12-01 08:59 UTC, Jaroslav Franek
no flags Details
Xorg log under User Mode Setting (36.42 KB, application/octet-stream)
2009-12-01 09:00 UTC, Jaroslav Franek
no flags Details
Xorg log under Kernel Mode Setting (29.42 KB, application/octet-stream)
2009-12-01 09:00 UTC, Jaroslav Franek
no flags Details
dmesg under User Mode Setting (43.51 KB, text/plain)
2009-12-01 09:11 UTC, Jaroslav Franek
no flags Details
dmesg under Kernel Mode Setting (45.81 KB, text/plain)
2009-12-01 09:13 UTC, Jaroslav Franek
no flags Details
Xorg log under User Mode Setting (36.42 KB, text/plain)
2009-12-01 09:13 UTC, Jaroslav Franek
no flags Details
Xorg log under Kernel Mode Setting (29.42 KB, text/plain)
2009-12-01 09:15 UTC, Jaroslav Franek
no flags Details
Distortion on the screen with nouveau under KMS (1.47 MB, image/jpeg)
2009-12-01 23:09 UTC, Jaroslav Franek
no flags Details

Description Jaroslav Franek 2009-11-21 20:06:51 UTC
Description of problem:
When using KMS (default) the fonts on the screen are distorted, barely readable, in many cases beyond recognition. Graphical elements of the user interface are also rendered imperfectly.

Works fine if the KMS is disabled (nomodeset in kernel boot params).

Graphics Adapter: nvidia GT130, 768MB, DVI interface
Graphics Mode: 1920x1200 @ 60Hz
Driver: nouveau


Version-Release number of selected component (if applicable):
kernel-2.6.31.6-134.fc12.x86_64


How reproducible:
just boot using kms, affects logging screen as well, KDE session is barely usable, virtual terminals are affected too

Steps to Reproduce:
1.
2.
3.
  
Actual results:
distorted image on the screen

Expected results:
clean picture on the screen

Additional info:
I have tried several screen grabbers, but the image always comes clean without any distortion. Unfortunately I do not have digital camera at the moment to capture the distortion... maybe later.

Comment 1 Michael Breuer 2009-12-01 06:31:06 UTC
    Thanks for the bug report. We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue. 

    Please attach your X server config file (/etc/X11/xorg.conf), X server log file (/var/log/Xorg.*.log) and the output of "dmesg" to the bug report as individual uncompressed text/plain file attachments using the bugzilla file attachment link below. 

    Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please. 

    We will review this issue again once you've had a chance to attach this information. 

    Thank you in advance. 

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Jaroslav Franek 2009-12-01 08:58:14 UTC
Created attachment 374991 [details]
dmesg under User Mode Settings

Comment 3 Jaroslav Franek 2009-12-01 08:59:05 UTC
Created attachment 374992 [details]
dmesg under Kernel Mode Setting

Comment 4 Jaroslav Franek 2009-12-01 09:00:01 UTC
Created attachment 374993 [details]
Xorg log under User Mode Setting

Comment 5 Jaroslav Franek 2009-12-01 09:00:41 UTC
Created attachment 374994 [details]
Xorg log under Kernel Mode Setting

Comment 6 Jaroslav Franek 2009-12-01 09:06:57 UTC
All logs taken right after boot from console virtual terminal (without user login into KDE). No xorg.conf in use.

Additional info:

LCD Screen: Acer AL2423W, Native resolution 1920x1200 @60Hz.

Using: xorg-x11-drv-nouveau-0.0.15-18.20091105gite1c2efd.fc12.x86_64

Comment 7 Jaroslav Franek 2009-12-01 09:11:59 UTC
Created attachment 374995 [details]
dmesg under User Mode Setting

Comment 8 Jaroslav Franek 2009-12-01 09:13:00 UTC
Created attachment 374996 [details]
dmesg under Kernel Mode Setting

Comment 9 Jaroslav Franek 2009-12-01 09:13:36 UTC
Created attachment 374997 [details]
Xorg log under User Mode Setting

Comment 10 Jaroslav Franek 2009-12-01 09:15:07 UTC
Created attachment 374998 [details]
Xorg log under Kernel Mode Setting

Sorry I screwed up MIME type (autodetection did not work out), posting again with text/plain.

Comment 11 Michael Breuer 2009-12-01 21:02:56 UTC
Note: 2.6.31.6-145.fc12.x86_64 now (from dmesg).

Ben, 

Not sure if this is nouveau or kernel - diff between the two dmesg file is interesting.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 12 Jaroslav Franek 2009-12-01 23:09:59 UTC
Created attachment 375232 [details]
Distortion on the screen with nouveau under KMS

As promised the snapshot of the screen. I am not a good photographer but still the distortion on the screen is apparent. The text in the konsole (on the right) is dmesg output - barely readable.

Any attempt to use a screen capture program (under KMS), the image comes nice and clean without any distortion.

Comment 13 Orion Poplawski 2009-12-03 23:07:27 UTC
I'll tag on to this as well for now - display corruption on:

NV18GL [Quadro NVS 280 SD] (rev a2)
xorg-x11-drv-nouveau-0.0.15-18.20091105gite1c2efd.fc12.i686
2.6.31.6-145.fc12.i686.PAE

nomodeset fixes.

Comment 14 Ben Skeggs 2009-12-04 01:54:38 UTC
Orion: Completely different codepaths for your bug, are you able to file another, with the same logs that were provided for this one?  Thanks!

Comment 15 Orion Poplawski 2009-12-04 16:51:37 UTC
Sure, filed bug 544338

Comment 16 Cristian Ciupitu 2009-12-27 02:43:05 UTC
Please have a look at bug #550720 and check if it's the same or not. Thanks!

Comment 17 Jaroslav Franek 2010-03-07 20:44:48 UTC
Hi Ben,

I have noticed that in nouveau the UMS support is being dropped, so I am checking the state of this bug. At this moment I am running the kernel: 

2.6.32.9-67.fc12.x86_64 #1 SMP Sat Feb 27 09:26:40 UTC 2010

The issue is still present so I am forced to use the UMS.

Comment 18 Jaroslav Franek 2010-03-23 19:59:44 UTC
Just to let you know the bug is still present in Fedora 13 Alpha. Changing version to 13.

Note that I have tested the KDE Live CD only.

Comment 19 Jaroslav Franek 2010-03-30 22:00:15 UTC
Checked bug #550720, distortion looks very different, and also in my case the rendering in buffers was fine - when I did screen capture from within KDE, it came out without distortion.

With VGA-0 the KMS works fine. Looks like the monitor is not programmed correctly when using KMS & DVI-I. I suspect some kind of quirk is needed for the monitor type I use...

My Xorg.0.log only shows that the first listed mode 1920x1200 (native resolution) is disposed of as bad mode:

(II) NOUVEAU(0): Not using mode "1920x1200" (bad mode clock/interlace/doublescan)

At the moment using:

kernel-2.6.32.10-92.fc12.x86_64
xorg-x11-drv-nouveau-0.0.15-21.20091105gite1c2efd.fc12.x86_64

issue still present, but at least I have finally got an old VGA cable...

Comment 20 Jaroslav Franek 2010-06-03 17:37:26 UTC
I have tried the DVI cable again with F13 and its kernel-2.6.33.5-112.fc13.x86_64 and the problem is gone. DVI now works well.

The problem was reported against F12, but I do not use it anymore so I cannot test it. Since I was apparently the only one with this specific issue, I think it is safe to close this bug.


Note You need to log in before you can comment on or make changes to this bug.