Bug 53998 - Oops in generic_unplug_device
Oops in generic_unplug_device
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-25 05:56 EDT by Pekka Pietikäinen
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-26 04:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2001-09-25 05:56:24 EDT
With 2.4.7-10, it appears like the kernel oopsed
while running cdrecord:


Unable to handle kernel paging request at virtual address 8f66fcaf
c017f5d8
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<c017f5d8>]
Using defaults from ksymoops -t elf32-i386 -a i386
EFLAGS: 00010092
eax: 8f66fc37   ebx: 00000292   ecx: 00000000   edx: 8f66fc37
esi: c7f0b064   edi: c7f0b040   ebp: cfe35de0   esp: cfe35d7c
ds: 0018   es: 0018   ss: 0018
Process cdrecord (pid: 8664, stackpage=cfe35000)
Stack: cee2bb80 d228af67 8f66fc37 cee2bb80 cfe35de0 00000000 00000000
d228bc90 
       00000fa0 00000001 00000000 080752b2 cfe35de6 c7f0b000 d228acee
c7f0b000 
       c7f0b040 cfe35de0 00000fa0 00000001 0000013a cfe34000 00000fa0
c7f0b040 
Call Trace: [<d228af67>] [<d228bc90>] [<d228acee>] [<d228d6c1>]
[<d228b230>] 
   [<c012f370>] [<d228dec1>] [<c012d5b8>] [<c012f013>] [<c012f116>]
[<c012f2cf>] 
   [<c0124b76>] [<c0124c62>] [<c0124da5>] [<c0125cb4>] [<c0124f79>]
[<c0126052>] 
   [<c0143767>] [<c0106f0b>] 
Code: 80 7a 78 00 74 11 c6 42 78 00 8d 42 28 39 42 28 74 05 52 ff 

>>EIP; c017f5d8 <generic_unplug_device+8/30>   <=====
Trace; d228af67 <[sg]sg_common_write+247/260>
Trace; d228bc90 <[sg]sg_cmd_done_bh+0/310>
Trace; d228acee <[sg]sg_new_write+1ce/200>
Trace; d228d6c1 <[sg]sg_build_reserve+51/70>
Trace; d228b230 <[sg]sg_ioctl+2b0/bb0>
Trace; c012f370 <__get_free_pages+10/20>
Trace; d228dec1 <[sg]sg_low_malloc+131/1a0>
Trace; c012d5b8 <reclaim_page+268/370>
Trace; c012f013 <__alloc_pages_limit+63/90>
Trace; c012f116 <_wrapped_alloc_pages+b6/260>
Trace; c012f2cf <__alloc_pages+f/a0>
Trace; c0124b76 <do_anonymous_page+36/f0>
Trace; c0124c62 <do_no_page+32/110>
Trace; c0124da5 <handle_mm_fault+65/e0>
Trace; c0125cb4 <do_munmap+64/260>
Trace; c0124f79 <make_pages_present+49/70>
Trace; c0126052 <do_brk+152/160>
Trace; c0143767 <sys_ioctl+177/190>
Trace; c0106f0b <system_call+33/38>
Code;  c017f5d8 <generic_unplug_device+8/30>
00000000 <_EIP>:
Code;  c017f5d8 <generic_unplug_device+8/30>   <=====
   0:   80 7a 78 00               cmpb   $0x0,0x78(%edx)   <=====
Code;  c017f5dc <generic_unplug_device+c/30>
   4:   74 11                     je     17 <_EIP+0x17> c017f5ef
<generic_unplug_device+1f/30>
Code;  c017f5de <generic_unplug_device+e/30>
   6:   c6 42 78 00               movb   $0x0,0x78(%edx)
Code;  c017f5e2 <generic_unplug_device+12/30>
   a:   8d 42 28                  lea    0x28(%edx),%eax
Code;  c017f5e5 <generic_unplug_device+15/30>
   d:   39 42 28                  cmp    %eax,0x28(%edx)
Code;  c017f5e8 <generic_unplug_device+18/30>
  10:   74 05                     je     17 <_EIP+0x17> c017f5ef
<generic_unplug_device+1f/30>
Code;  c017f5ea <generic_unplug_device+1a/30>
  12:   52                        push   %edx
Code;  c017f5eb <generic_unplug_device+1b/30>
  13:   ff 00                     incl   (%eax)
Comment 1 Pekka Pietikäinen 2003-09-26 04:28:10 EDT
I'm quite sure this bug doesn't exist anymore in the latest kernels, never seen
it since so might as well close it.

Note You need to log in before you can comment on or make changes to this bug.