Bug 539986 - [abrt] crash detected in eclipse-pydev-1:1.4.7-3.fc12
Summary: [abrt] crash detected in eclipse-pydev-1:1.4.7-3.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-pydev
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:512bd048
: 567671 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-21 20:51 UTC by Nikolay Bryskin
Modified: 2010-07-13 08:19 UTC (History)
43 users (show)

Fixed In Version: eclipse-pydev-1.5.5-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 578399 (view as bug list)
Environment:
Last Closed: 2010-07-13 07:40:42 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (2.67 KB, text/plain)
2009-11-21 20:51 UTC, Nikolay Bryskin
no flags Details
Patch removing the RuntimeError used for normal termination (505 bytes, patch)
2010-06-11 13:56 UTC, Mads Kiilerich
no flags Details | Diff

Description Nikolay Bryskin 2009-11-21 20:51:16 UTC
abrt detected a crash.

Comment
-----
1. Start eclipse
2. Import google protocol buffers project
3. Configure windows->preferences->pydev->python 

Attached file: backtrace
cmdline: /usr/bin/python -u /usr/lib64/eclipse/dropins/pydev/eclipse/plugins/org.python.pydev_1.4.7.2843/PySrc/interpreterInfo.py 
component: eclipse-pydev
executable: /usr/lib64/eclipse/dropins/pydev/eclipse/plugins/org.python.pydev_1.4.7.2843/PySrc/interpreterInfo.py
kernel: 2.6.31.5-127.fc12.x86_64
package: eclipse-pydev-1:1.4.7-3.fc12
uuid: 512bd048

Comment 1 Nikolay Bryskin 2009-11-21 20:51:19 UTC
Created attachment 372795 [details]
File: backtrace

Comment 2 Alexander Kurtakov 2009-11-22 13:12:42 UTC
Can you try with pydev 1.5.0 which is in update testing?

Comment 3 Alexander Kurtakov 2009-11-23 13:05:53 UTC
I didn't manage to reproduce it with 1.4.7.

Comment 4 Andrew Overholt 2009-11-23 14:45:46 UTC
That backtrace is hard to parse.  I wonder if this had anything to do with the HotSpot crash we work around in eclipse.ini (but was missing in early F-12 versions)?

Comment 5 Nikolay Bryskin 2009-11-23 18:43:51 UTC
Steps to reproduce:
1. Start eclipse
2. Import google protocol buffers project
3. Configure windows->preferences->pydev->Interpreter - Python 
4. Remove all python interpreters
5. Press Auto Config

Comment 6 Nikolay Bryskin 2009-11-23 18:54:55 UTC
I have tried with pydev 1.5.0 - behaviour is the same: crash on Auto Config.

Comment 7 Nikolay Bryskin 2009-11-23 18:56:42 UTC
PS: eclipse working fine after that

Comment 8 Andrew Overholt 2009-11-23 19:32:35 UTC
Please be more specific with what to import.  A link to a tarball and explicit "import these files or this directory" would be appreciated.

Also, does this give any output?

grep -i pydev /usr/lib64/eclipse/eclipse.ini

Try adding the following line -- it's all one line -- to /usr/lib64/eclipse/eclipse.ini and re-start Eclipse to see if it helps:

-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles

Oh yeah, could you also please look in ~/.xsession-errors and see if there's a better stack trace (ie. a java stack trace) for the crash you're experiencing?

Comment 9 Alexander Kurtakov 2009-11-24 10:34:38 UTC
Hmm, any chances that you're hit by the bug described here http://pydev.blogspot.com/2009/11/pyqt4-bug-preventing-it-from-working.html ??
If yes please change the component to PyQT4 it is a really easy to reproduce the crash on the console though I didn't managed to reproduce it in Eclipse

Comment 10 Alexander Kurtakov 2009-11-24 10:42:58 UTC
Oh, do you mean that eclipse itself doesn't crash and it stays and works but abrt catches python crash?

Comment 11 Alexander Kurtakov 2009-11-24 10:48:56 UTC
The easiest way to determine whether it it PyQt4 problem:
yum remove PyQt4 
try auto config again and see whether the crash will be catched?

Comment 12 Nikolay Bryskin 2009-11-25 07:19:28 UTC
(In reply to comment #10)
> Oh, do you mean that eclipse itself doesn't crash and it stays and works but
> abrt catches python crash?  

Yes

Comment 13 Nikolay Bryskin 2009-11-25 07:21:23 UTC
(In reply to comment #9)
> Hmm, any chances that you're hit by the bug described here
> http://pydev.blogspot.com/2009/11/pyqt4-bug-preventing-it-from-working.html ??
> If yes please change the component to PyQT4 it is a really easy to reproduce
> the crash on the console though I didn't managed to reproduce it in Eclipse  

Thanks, I will try to workaround it.

Comment 14 Alexander Kurtakov 2009-11-25 11:14:12 UTC
Will you close the  bug or reassign to other component?

Comment 15 Nikolay Bryskin 2009-11-26 18:58:26 UTC
(In reply to comment #13)
> (In reply to comment #9)
> > Hmm, any chances that you're hit by the bug described here
> > http://pydev.blogspot.com/2009/11/pyqt4-bug-preventing-it-from-working.html ??
> > If yes please change the component to PyQT4 it is a really easy to reproduce
> > the crash on the console though I didn't managed to reproduce it in Eclipse  
> 
> Thanks, I will try to workaround it.  

I have not PyQT4 installed.

Comment 16 Alexander Kurtakov 2009-12-04 08:37:17 UTC
Hmm, is there some pydev error in Error view? 
Maybe it is some other python module that crashes the interpreter?

Comment 17 Nikolay Bryskin 2009-12-06 19:39:30 UTC
Solved! /usr/lib64/eclipse/dropins/
66/PySrc/interpreterInfo.py:138

...
    raise RuntimeError('Ok, this is so that it shows the output (ugly hack for some platforms, so that it releases the output).')



After just commenting this line all is OK.

Thanks for assistance!

Comment 18 Mads Kiilerich 2010-01-19 11:59:31 UTC
(In reply to comment #17)
> Solved! /usr/lib64/eclipse/dropins/
> 66/PySrc/interpreterInfo.py:138

I tend to disagree.

The exception is intentionally thrown in interpreterInfo.py - apparently every time "auto config" is run. That is ugly, but not really a problem in itself. But it becomes a problem when abrt catches such exceptions and reports them. Such false reports gives both abrt and pydev a bad reputation.

Manually disabling the exception makes the problem go away, but that is a workaround to something which in no way is a showstopper. Knowing how to disable the exception does however not qualify as a solution. IMHO.

The hack might be a "solution" on some platforms, but in Fedora where everything is under control it shouldn't be necessary.

Comment 19 Andrew Overholt 2010-01-19 15:39:10 UTC
Mads, should an abrt bug be filed?

Comment 20 Mads Kiilerich 2010-01-19 15:53:31 UTC
I don't know ... I don't think so.

There is an incompatibility, and it should be resolved somehow. Whatever you can agree on ;-)

Abrt has hardcoded some exceptions, and perhaps more could be added - especially if there is a general rule. Abrts practice of implementing a _really_ global exception handler in Python can be questioned, but I think the practice of exiting a program by throwing an unhandled exception is even more questionable. I think it is a fine assumption that no program should coredump or throw unhandled exceptions.

Hmm. /usr/lib/python2.6/site-packages/abrt_exception_handler.py explicitly ignores KeyboardInterrupt. Perhaps interpreterInfo.py could throw that instead? Whether that works depends on what problem they are trying to "solve" with that exception...

Comment 21 Andrew Overholt 2010-02-23 16:19:57 UTC
*** Bug 567671 has been marked as a duplicate of this bug. ***

Comment 22 Jason Kankiewicz 2010-04-04 21:00:03 UTC

Comment
-----
Created a PyDev project containing a PyDev package. Whilst creating the PyDev project I selected the Python interpreter.

Comment 23 Chris Aniszczyk 2010-04-05 15:00:34 UTC
Do you have an actual problem Jason, your comment doesn't indicate a problem besides you creating a PyDev project and selecting an interpreter.

Any more details?

Comment 24 Mads Kiilerich 2010-04-06 08:37:13 UTC
(In reply to comment #23)
> Do you have an actual problem Jason, your comment doesn't indicate a problem
> besides you creating a PyDev project and selecting an interpreter.
> 
> Any more details?    

/me chimes in ...

Jasons comment was entered as a comment in abrt-gui because it detected a crash. Bug 575396 proposes a better workflow for adding mee-too comments.

So the problem here remains: pydev intentionally crashes, abrt does its job and tells the user, the user gets a bit frightened and confused, and the skilled, friendly and loyal users will spend (a bit) time to report it upstream - here.

Comment 25 Stephen Gallagher 2010-04-19 16:04:50 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Open Eclipse
2. Open Workspace preferences
3. Select Interpreter - Python under Pydev
4. Click on 'Auto Config'


Comment
-----
See steps to reproduce. This happened consistently with three different attempts.

Comment 26 Alexey Kuznetsov 2010-05-06 19:16:22 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
add python interpretater to pydev project

Comment 27 Muayyad Alsadi 2010-05-28 08:20:55 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
it happened when I tried to add /usr/bin/python as a python 2.6 interpreter

Comment
-----
eclipse continued to work perfectly, the only indicate that there is a bug was abrt

Comment 28 QFanatic 2010-06-08 14:56:13 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Eclipse running
2.Selected Auto Config under python interpreters
3.

Comment 29 Jan Sedlák 2010-06-11 09:38:43 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Install python, install eclipse IDE, install python plugin for eclipse
2.Add python interpreter into eclipse
3.Profit


Comment
-----
I have simply added path to python into eclipse settings while creating new python project and it crashed.

Comment 30 Mads Kiilerich 2010-06-11 10:12:55 UTC
Eclipse packagers: 
Could you please apply a patch that removes the "raise RuntimeError"?

If not: could you please ask the abrt guys to black/white-list this exception?

Comment 31 Andrew Overholt 2010-06-11 13:11:30 UTC
Does anyone have a patch?

Comment 32 Mads Kiilerich 2010-06-11 13:56:20 UTC
Created attachment 423281 [details]
Patch removing the RuntimeError used for normal termination

This trivial patch works fine:

--- /usr/lib/eclipse/dropins/pydev/eclipse/plugins/org.python.pydev_1.5.5.2010030420/PySrc/interpreterInfo.py.org	2010-06-11 12:08:17.000000000 +0200
+++ /usr/lib/eclipse/dropins/pydev/eclipse/plugins/org.python.pydev_1.5.5.2010030420/PySrc/interpreterInfo.py	2010-06-11 15:51:07.000000000 +0200
@@ -134,5 +134,3 @@
         time.sleep(0.1)
     except:
         pass
-    
-    raise RuntimeError('Ok, this is so that it shows the output (ugly hack for some platforms, so that it releases the output).')


Linux is apparently and hopefully not one of the platforms that needs this hack.

Comment 33 Peter Andreasen 2010-06-17 19:31:59 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Start eclipse
2. Start (for the first time) a pydev project
3.

Comment 34 Abhishek Singh 2010-06-29 06:42:22 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Open Eclipse
2. Set the Perspecitive to "PyDev"
3. Preferences > Pydev > Intepreter - Python > Auto Config



Comment
-----
I tried "Auto Config" and added all the items. While eclipse was adding those items, ABRT reported a crash, but eclipse went running well without any errors. I suspect this is a false trigger ran by ABRT.

Comment 35 Andrew Overholt 2010-06-30 14:42:20 UTC
I included Mads' patch in this build:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=2283583

It fixes the problem for me but I'd appreciate others trying it out.

Comment 36 yyetim 2010-07-05 22:38:13 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. install eclipse-pydev
2. Autoconfig python interpreter
3.

Comment 37 Fedora Update System 2010-07-06 12:53:28 UTC
eclipse-pydev-1.5.5-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/eclipse-pydev-1.5.5-2.fc13

Comment 38 Fedora Update System 2010-07-07 17:49:28 UTC
eclipse-pydev-1.5.5-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eclipse-pydev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/eclipse-pydev-1.5.5-2.fc13

Comment 39 Eric Poelke 2010-07-10 14:15:55 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Create new pydev project in eclipse
2. click auto-config to find interpreter
3. crash message appears but process seems to succeed 


Comment
-----
Same crash message occurs if auto config or manually selecting /usr/bin/python.  Everything seems to work fine after the error message.

Comment 40 wesley.massuda 2010-07-10 16:23:18 UTC
Package: eclipse-pydev-1:1.5.5-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.just click autoconfig button of python interpreter
2.
3.

Comment 41 Andrew Overholt 2010-07-12 12:31:22 UTC
Has anyone tried the update in comment #38?

Comment 42 Fedora Update System 2010-07-13 07:40:34 UTC
eclipse-pydev-1.5.5-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.