Bug 539993 - Interface tab missing from gnome-appearance-properties
Interface tab missing from gnome-appearance-properties
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
12
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 539258
  Show dependency treegraph
 
Reported: 2009-11-21 16:25 EST by Joel Uckelman
Modified: 2010-01-25 09:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-25 01:37:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joel Uckelman 2009-11-21 16:25:47 EST
Description of problem:

There is no Interface tab in gnome-appearance-properties. There was one in F11, and the F12 Release notes claim there should be one (see Bug 539258), as does 
the text shown by 'gnome-appearance-properties -h'.

Version-Release number of selected component (if applicable):

control-center-2.28.1-4.fc12.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Go go System > Preference > Appearance OR run gnome-appearance-properties from a terminal.
  
Actual results:

No Interface tab.

Expected results:

Interface tab.


Additional info:

Running 'gnome-appearance-properties -p interface' also doesn't bring up the Iterface tab.
Comment 1 Tomasz Chrzczonowicz 2009-12-08 11:36:56 EST
I think the severity of this bug should be "high" or at least "medium". It's a major loss of functionality.
Comment 2 Ray Strode [halfline] 2009-12-09 10:08:28 EST
It was intentionally removed.  It probably makes sense to add it back as a separate tweak ui dialog that's separately installable. 

Note we don't use the severity field for prioritizing bugs.
Comment 3 Tomasz Chrzczonowicz 2009-12-09 15:04:22 EST
How come Release Note tells people to use it, if it was removed? And how come other distros have it?

http://docs.fedoraproject.org/release-notes/f12/en-US/html/sect-Release_Notes-Changes_in_Fedora_for_Desktop_Users.html#sect-Release_Notes-Fedora_Desktop

"4.1.4.1. Icons in menus and buttons
Icons in menus and buttons are not shown by default in GNOME 2.28. To get the old, icon-rich appearance back, select System → Preferences → Appearance, click the Interface tab and enable Show icons in menus. There is, however, no menu interface to enable the icons for the buttons. To set the corresponding GConf keys instead for enabling both the menus and buttons to have icons:

gconftool-2 --type boolean --set /desktop/gnome/interface/buttons_have_icons true
gconftool-2 --type boolean --set /desktop/gnome/interface/menus_have_icons true"

Removing existing functionality from GUI and telling people to use gconf or re-implement the previously perfectly good feature in some obscure add-in is not an advancement in usability. It's simply crippling the Desktop and making users' lives harder.
Comment 4 Neal Dias 2010-01-16 22:03:44 EST
Why would we intentionally remove it in the first place?

And why would we add it back as a seperate UI? 

Add it back in the original location, where users are accustomed to finding it, where it is located in other distributions, and where the release notes say it is. Lets not make it even more confusing for the user by adding it back somewhere else.

This is a functionality regression, for little good reason it appears. Please put it back.
Comment 5 Joel Uckelman 2010-01-25 05:06:06 EST
Wait, why was this closed? What are we supposed to do to get this fixed if you guys won't fix it?
Comment 6 Matthias Clasen 2010-01-25 08:37:14 EST
There is nothing to fix here, really. We decided that the options on the interface tab were not useful enough for the majority of users, and upstream agreed with us. 

There will always be a few people who decry the loss of any option, no matter how obscure it is. 

Since we have no intention to bring this tab back, it seems the most honest to close this as WONTFIX.
Comment 7 Joel Uckelman 2010-01-25 08:52:36 EST
Ok, so then we need to work on convincing upstream that it should be put back. That's the information I wanted. Thanks for the explanation.
Comment 8 Neal Dias 2010-01-25 09:02:41 EST
<snip>
There is nothing to fix here, really. We decided that the options on the
interface tab were not useful enough for the majority of users, and upstream
agreed with us. 

There will always be a few people who decry the loss of any option, no matter
how obscure it is. 

Since we have no intention to bring this tab back, it seems the most honest to
close this as WONTFIX.    
<snip>

It's not obscure if you use your a desktop and like to tweak your appearances. And who decided this was obscure? Why did you decide it was obscure? On what basis are you concidering this obscure?

If you worked with upstream to remove this functionality, again, for no apparent reason other than a decision based on opinion, then you can certainly work with them to get the functionality back. You had no good reason to remove it, your getting user complaints... work with upstream to get it back since yuo apparently caused this mess by convincing upstream to remove functionality users are accustomed to without providing an alternative route to that functionality.

Note You need to log in before you can comment on or make changes to this bug.