Bug 540061 - CJK text regression (w/ screenshots)
Summary: CJK text regression (w/ screenshots)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cjkuni-fonts
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-22 04:05 UTC by Cong Ma
Modified: 2010-09-29 03:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-29 03:21:09 UTC
Type: ---


Attachments (Terms of Use)
Screenshot of XFCE4 input method setting tool. Note the coarse text (17.82 KB, image/png)
2009-11-22 04:05 UTC, Cong Ma
no flags Details
F12 YUMEX screenshot (21.94 KB, image/png)
2009-11-22 04:08 UTC, Cong Ma
no flags Details
F12 GIMP screenshot (41.60 KB, image/png)
2009-11-22 04:10 UTC, Cong Ma
no flags Details

Description Cong Ma 2009-11-22 04:05:56 UTC
Created attachment 372855 [details]
Screenshot of XFCE4 input method setting tool. Note the coarse text

Description of problem:
I upgraded to Fedora 12 and to my surprise, some Chinese text that used to be displayed correctly now appears to be rendered ugly and broken.

Examples can be found in the attached screenshots. All shots are taken on the F12 system. Unfortunately I didn't take shots on the previous, working system (because it worked as expected) so there's no comparison.

On my current F12 install the font packages are almost the same as the previous F11 system. There are no additional fonts installed.

The installed CJK fonts are:

cjkuni-fonts-ghostscript-0.2.20080216.1-29.fc12.noarch
cjkuni-ukai-fonts-0.2.20080216.1-29.fc12.noarch
cjkuni-uming-fonts-0.2.20080216.1-29.fc12.noarch

wqy-bitmap-fonts-0.9.9-11.fc12.noarch
wqy-unibit-fonts-1.1.0-7.fc12.noarch
wqy-zenhei-fonts-0.8.38-3.fc12.noarch

xorg-x11-fonts-misc-7.2-9.fc12.noarch

I'm not sure whether this bug should be reported against this package or any of the font packages. I really don't know. I just guessed this could possibly be a fontconfig problem, since I didn't change the fonts.

The Appearance setting is also inherited from the previous install. The default font used is "DejaVu Sans 9". In F11 it used to do the right thing with this setting (displaying Western text in DejaVu Sans and render CJK text beautifully). I didn't change anything.

Also, subpixel antialiasing seems to have stopped working for CJK text too. 


Version-Release number of selected component (if applicable):
fontconfig-2.7.3-1.fc12.i686


Additional info:
I guess the cause of this issue is complex, but I have to choose a package to report the bug against ;) If you feel it's necessary, please also inform the font maintainers of this issue.

Thanks.

Comment 1 Cong Ma 2009-11-22 04:08:37 UTC
Created attachment 372857 [details]
F12 YUMEX screenshot

The rendered text in the red circle is the most offending. Also the larger characters doesn't appear quite right even with subpixel on.

Comment 2 Cong Ma 2009-11-22 04:10:16 UTC
Created attachment 372859 [details]
F12 GIMP screenshot

The small characters displayed in this GIMP sidepanel appears utterly illegible.

Comment 3 Jens Petersen 2010-03-03 09:24:12 UTC
Can you reproduce in gucharmap?  And identify which font has the problem?

Comment 4 Qianqian Fang 2010-03-04 16:00:43 UTC
try to search "antialias" in the conf.d folder. UMing should set 10px (or 11px) as the smallest font size for antialias=false.

Comment 5 Cong Ma 2010-03-05 06:07:25 UTC
(In reply to comment #4)
> try to search "antialias" in the conf.d folder. UMing should set 10px (or 11px)
> as the smallest font size for antialias=false.    

Thanks for the comment. Lowering the threshold value seems to have fixed the problem for me.

Any reason for the particular choice of 10px or 11px? The GIMP seems to require a smaller value to display the small characters properly.

Comment 6 Jens Petersen 2010-03-05 08:17:44 UTC
This should be fixed in F13 already btw since I dropped the bitmap .conf there.

Perhaps you could test the current rawhide/f13 package is ok for you?

Comment 7 Fedora Admin XMLRPC Client 2010-07-15 00:31:12 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 8 James Ni 2010-09-29 03:24:38 UTC
I have test yumex, gimp and imchooser on my F13 machine, it is ok for me. The problem have fixed in F13.


Note You need to log in before you can comment on or make changes to this bug.