Bug 540064 - X Hangs for 90 seconds on login and when clicking the KDE menu
Summary: X Hangs for 90 seconds on login and when clicking the KDE menu
Status: CLOSED DUPLICATE of bug 533620
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-22 04:24 UTC by josh
Modified: 2018-04-11 09:48 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-12-05 10:24:01 UTC


Attachments (Terms of Use)
output of 'top -s 1 | tee toptest' during hang, KDE menu was clicked at ~23:05:30 (128.86 KB, text/plain)
2009-11-22 04:24 UTC, josh
no flags Details
strace of /usr/bin/X during hang, KDE menu was clicked at ~23:09:48 (1.36 MB, text/plain)
2009-11-22 04:27 UTC, josh
no flags Details
Output of strace of /usr/bin/X (438.99 KB, text/plain)
2009-11-30 14:46 UTC, Patrick
no flags Details
Output of top during freeze (44.18 KB, text/plain)
2009-11-30 14:48 UTC, Patrick
no flags Details
Output of dmesg (40.89 KB, text/plain)
2009-11-30 14:50 UTC, Patrick
no flags Details
Output of uname (104 bytes, text/plain)
2009-11-30 14:50 UTC, Patrick
no flags Details
xorg.conf (421 bytes, text/plain)
2009-11-30 14:52 UTC, Patrick
no flags Details
Xorg.0.log (12.78 KB, text/plain)
2009-11-30 14:53 UTC, Patrick
no flags Details
Xorg.0.log.old (24.25 KB, text/plain)
2009-11-30 14:53 UTC, Patrick
no flags Details
Xorg.9.log (21.33 KB, text/plain)
2009-11-30 14:54 UTC, Patrick
no flags Details
Output of yum info kmod-nvidia (excerpt) (158 bytes, text/plain)
2009-11-30 14:56 UTC, Patrick
no flags Details
Output of nvidia-bug-report (36.87 KB, application/x-gzip)
2009-11-30 15:06 UTC, Patrick
no flags Details
xorg.conf created by nvidia-settings (2.04 KB, text/plain)
2009-11-30 15:17 UTC, Patrick
no flags Details

Description josh 2009-11-22 04:24:47 UTC
Created attachment 372861 [details]
output of 'top -s 1 | tee toptest' during hang, KDE menu was clicked at ~23:05:30

Description of problem:

X hangs for approximately 90 seconds both on initial login and anytime the KDE menu is accessed (click the KDE menu to access apps, right click a plasmoid).  The mouse moves, but no other input is taken and the clock and all other video is frozen during that time.

Version-Release number of selected component (if applicable): F12 using the proprietary NVIDIA driver (kmod-nvidia) from rpmfusion-nonfree-updates-testing, kernel kernel-2.6.31.5-127.fc12.x86_64


How reproducible:


Steps to Reproduce:
1. Log in to a KDE Session
2. Click the KDE start menu
3.
  
Actual results:
Hangs 90 seconds before showing the menu

Expected results:
Show the menu immediately

Additional info:
This system was just upgraded from F11 to F12 via preupgrade.  Problem did not occur under F11

Comment 1 josh 2009-11-22 04:27:08 UTC
Created attachment 372862 [details]
strace of /usr/bin/X during hang, KDE menu was clicked at ~23:09:48

You can see a a lot of waiting for SIGALRM during the hang, control returned ~23:11:17

Comment 2 Matěj Cepl 2009-11-27 17:20:48 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 Richard Allen 2009-11-27 22:21:54 UTC
I have the same setup and see the same behavior.   However for me it's just 3-5 seconds but still annoying :)

Comment 4 Patrick 2009-11-30 03:11:22 UTC
Exactly the same problem here with x86_64 and i686. KDE hangs for about 20 seconds after several actions like clicking on KDE menu button, ALT+F2 or ALT+CRTL+Fn. The mouse cursor still works but nothing else. I tried kmod-nvidia / akmod-nvidia for x86_64 and kmod-nvidia-PAE / akmod-nvidia for i686. The opensource drivers work (within their limited specifications). I was using F10 for about a year with nvidia drivers and experienced no such problems.

Comment 5 Patrick 2009-11-30 03:20:59 UTC
I want to provide useful debug information, but I don't know how to generate "strace of /usr/bin/X". Is this really needed and if yes can you please give me advice how to produce it?

Comment 6 Patrick 2009-11-30 14:46:09 UTC
Created attachment 374764 [details]
Output of strace of /usr/bin/X

[root@mimic patrick]# ps ax | grep X
1469 tty1     Ss+    3:35 /usr/bin/X -br -nolisten tcp :0 vt1 -auth /var/run/kdm/A:0-mtrHix
[root@mimic patrick]# strace -p 1469 -o strace_out.txt

// then click on KDE Kickoff Application Launcher
// result: Desktop freeze, except mouse, for about 23 seconds

Comment 7 Patrick 2009-11-30 14:48:51 UTC
Created attachment 374765 [details]
Output of top during freeze

[root@mimic patrick]# top -S > top_out.txt

// X has nearly 100% CPU time during freeze

Comment 8 Patrick 2009-11-30 14:50:09 UTC
Created attachment 374767 [details]
Output of dmesg 

[root@mimic patrick]# dmesg > dmesg_out.txt

Comment 9 Patrick 2009-11-30 14:50:58 UTC
Created attachment 374768 [details]
Output of uname

[root@mimic patrick]# uname -a > uname_out.txt

Comment 10 Patrick 2009-11-30 14:52:06 UTC
Created attachment 374769 [details]
xorg.conf

Comment 11 Patrick 2009-11-30 14:53:02 UTC
Created attachment 374770 [details]
Xorg.0.log

Comment 12 Patrick 2009-11-30 14:53:36 UTC
Created attachment 374771 [details]
Xorg.0.log.old

Comment 13 Patrick 2009-11-30 14:54:09 UTC
Created attachment 374772 [details]
Xorg.9.log

Comment 14 Patrick 2009-11-30 14:56:10 UTC
Created attachment 374773 [details]
Output of yum info kmod-nvidia (excerpt)

Comment 15 Patrick 2009-11-30 15:06:23 UTC
Created attachment 374776 [details]
Output of nvidia-bug-report

[root@mimic patrick]# nvidia-bug-report.sh

Comment 16 Patrick 2009-11-30 15:17:47 UTC
Created attachment 374782 [details]
xorg.conf created by nvidia-settings

xorg.conf generated by GUI application 'nvidia-settings'. After reboot the problem is still the same.

Comment 17 Patrick 2009-11-30 15:26:23 UTC
In /etc/X11/xorg.conf setting "Composite" to "Disable" solves the problem:

Section "Extensions"
    Option         "Composite" "Disable"
EndSection

But now KDE desktop effects can not be enabled, of course.

Comment 18 Patrick 2009-11-30 18:05:52 UTC
I think this is a duplicate of bug 533620.

Comment 19 Patrick 2009-11-30 20:30:58 UTC
This is definitely a duplicate of bug 533620. I followed the advice given there and updated packaged to xorg-x11-server-*-1.7.1-12.fc12.x86_64.rpm from the Fedora build system (binaries can be found here: http://koji.fedoraproject.org/koji/buildinfo?buildID=142860 ) and now everything works fine. :-)

Comment 20 Vedran Miletić 2009-12-05 10:24:01 UTC
Closing per comment #18 and comment #19.

*** This bug has been marked as a duplicate of bug 533620 ***


Note You need to log in before you can comment on or make changes to this bug.