Bug 54009 - gnome-terminal font selection broken
Summary: gnome-terminal font selection broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gtk+
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-25 14:28 UTC by Pedro Miguel Marques Morais
Modified: 2007-04-18 16:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2002-04-12 21:51:37 UTC


Attachments (Terms of Use)

Description Pedro Miguel Marques Morais 2001-09-25 14:28:08 UTC
Description of Problem:

gnome-terminal font selection dialog does not work, i.e, the font change
does not take effect

How Reproducible:

always.
on start, prints the following on the console:
-----------------cut here-------------------
 
Gdk-WARNING **: Missing charsets in FontSet creation
 
 
Gdk-WARNING **:     ISO8859-1
--------------cut here-------------------------

LANG was declare -x LANG="pt_PT.ISO-8859-1"  but it occurs after changing
it
to C.

Comment 1 Havoc Pennington 2002-02-26 16:27:43 UTC
You're probably choosing a font with the wrong encoding. If you uncheck "enable
multibyte support" it will let you choose a font with an encoding that doesn't
match the locale. 

I don't want to fix this in GNOME 1.x, except possibly to improve the error
message GTK prints when this happens since it's reported so often.
 Ideally GTK would print "font encoding is foo but locale encoding is bar,
unable to load font" or something like that. I don't know if GTK has enough info
to do that.

Comment 2 Owen Taylor 2002-04-12 21:51:33 UTC
gtk+-1.2.10-13 (now building) has improved warnings.



Note You need to log in before you can comment on or make changes to this bug.