Bug 540139 - KMS:RV370|M22:X300 - No usable output on laptop display
KMS:RV370|M22:X300 - No usable output on laptop display
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-22 10:06 EST by Mads Kiilerich
Modified: 2010-01-13 14:38 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-13 14:38:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (32.57 KB, text/plain)
2009-11-22 10:06 EST, Mads Kiilerich
no flags Details
dmesg from 2.6.31.6-157.fc12.i686.PAE with failing KMS (33.28 KB, text/plain)
2009-12-02 18:28 EST, Mads Kiilerich
no flags Details
dmesg - with drm.debug (63.79 KB, text/plain)
2010-01-06 19:34 EST, Mads Kiilerich
no flags Details
Xorg.0.log from working nomodeset session (43.12 KB, text/plain)
2010-01-06 19:35 EST, Mads Kiilerich
no flags Details
dmesg - with drm.debug and working KMS (39.14 KB, text/plain)
2010-01-13 14:34 EST, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-11-22 10:06:04 EST
Created attachment 372913 [details]
dmesg

Description of problem:

My Dell Latitude D610 doesn't work with KMS. The display shows "fading
psychedelic colors" when KMS kicks in, starting with a black display and slowly getting brighter and brighter in a non-digital way.

Except for that the machine works OK.

I guess the refresh of LCD display gets turned off when switching to graphics mode and that the crystals blocking twists thus slowly fades away.

It works OK without KMS when the X ati driver sets the graphics mode.


Version-Release number of selected component (if applicable):
2.6.31.6-145.fc12.i686.PAE - and "all" earlier versions
Comment 1 Dave Airlie 2009-11-30 19:57:23 EST
can you retry with 2.6.31.6-156 from koji I just added some fixes from upstream.
Comment 2 Mads Kiilerich 2009-12-01 18:20:52 EST
I just tried with 2.6.31.6-157.fc12.i686.PAE, and unfortunately I saw the same failing behaviour.
Comment 3 Mads Kiilerich 2009-12-02 18:28:15 EST
Created attachment 375618 [details]
dmesg from 2.6.31.6-157.fc12.i686.PAE with failing KMS

The machine booted fine to runlevel 3, the hd got quiet, and I could reboot with ctrl-alt-del
Comment 4 Mads Kiilerich 2009-12-04 07:00:25 EST
I noticed some radeon changes in kernel-PAE-2.6.31.6-161.fc12.i686, but still nu luck
Comment 5 François Cami 2009-12-29 10:35:51 EST
Hi   Mads,

Could you attach the dmesg log with drm.debug=1 in the kernel command line?

Thanks in advance

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Mads Kiilerich 2010-01-06 19:34:25 EST
Created attachment 382118 [details]
dmesg - with drm.debug

As requested ...
Comment 7 Mads Kiilerich 2010-01-06 19:35:53 EST
Created attachment 382119 [details]
Xorg.0.log from working nomodeset session

- just for reference
Comment 8 François Cami 2010-01-06 19:40:32 EST
Thank you Mads.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Mads Kiilerich 2010-01-06 19:50:28 EST
btw: Forgot to say that when I had booted with nomodeset and started X, removed nomodeset from grub.conf and used hibernate (suspend to disk) and resumed, then the kernel booted and started out in with KMS and this artifact, but when X was activated again it initialized video correctly, replacing the fading colors - probably because it remained in its nomodeset mode. So it seems like it is not that KMS destroys something - it just lacks something which X has.
Comment 10 Jérôme Glisse 2010-01-13 11:46:24 EST
Please try kernel from:

http://koji.fedoraproject.org/koji/buildinfo?buildID=150696

I should have the fix for LVDS and thus KMS should work with. Report if it works.
Comment 11 Mads Kiilerich 2010-01-13 14:34:42 EST
Created attachment 383545 [details]
dmesg - with drm.debug and working KMS

Yes, thanks, kernel-PAE-2.6.32.3-24.fc12.i686 works fine!

New dmesg attached, just in case someone wants to see _what_ it is that is working.

Note You need to log in before you can comment on or make changes to this bug.