Bug 540173 - SELinux is preventing /usr/bin/python "name_connect" access.
Summary: SELinux is preventing /usr/bin/python "name_connect" access.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:78e211e2b52...
: 540172 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-22 16:49 UTC by Eric Jansen
Modified: 2009-12-02 04:41 UTC (History)
4 users (show)

Fixed In Version: 3.6.32-49.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 16:41:03 UTC


Attachments (Terms of Use)

Description Eric Jansen 2009-11-22 16:49:32 UTC
Summary:

SELinux is preventing /usr/bin/python "name_connect" access.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by yumdownloader. It is not expected that this
access is required by yumdownloader and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0
Target Context                system_u:object_r:ftp_port_t:s0
Target Objects                None [ tcp_socket ]
Source                        yum
Source Path                   /usr/bin/python
Port                          21
Host                          (removed)
Source RPM Packages           python-2.6.2-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-46.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7
                              21:25:57 EST 2009 i686 i686
Alert Count                   2
First Seen                    Mon 23 Nov 2009 12:32:25 AM SGT
Last Seen                     Mon 23 Nov 2009 12:39:57 AM SGT
Local ID                      176fee1e-e5b2-4bea-b7cb-bb01e5a7ba1e
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1258907997.350:17): avc:  denied  { name_connect } for  pid=5138 comm="yumdownloader" dest=21 scontext=system_u:system_r:abrt_t:s0 tcontext=system_u:object_r:ftp_port_t:s0 tclass=tcp_socket

node=(removed) type=SYSCALL msg=audit(1258907997.350:17): arch=40000003 syscall=102 success=no exit=-115 a0=3 a1=bfa55730 a2=9b1f80 a3=bfa5599c items=0 ppid=13939 pid=5138 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="yumdownloader" exe="/usr/bin/python" subj=system_u:system_r:abrt_t:s0 key=(null)



Hash String generated from  selinux-policy-3.6.32-46.fc12,catchall,yum,abrt_t,ftp_port_t,tcp_socket,name_connect
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t ftp_port_t:tcp_socket name_connect;

Comment 1 Daniel Walsh 2009-11-23 15:49:35 UTC

You can add these rules for now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.6.32-48.fc12.noarch

Comment 2 Daniel Walsh 2009-11-23 15:49:59 UTC
*** Bug 540172 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2009-11-23 23:40:01 UTC
selinux-policy-3.6.32-49.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-49.fc12

Comment 4 Fedora Update System 2009-11-25 15:23:19 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12131

Comment 5 Fedora Update System 2009-12-02 04:34:28 UTC
selinux-policy-3.6.32-49.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.