Bug 540223 - xpaint's debuginfo is empty, pdfconcat not built with $RPM_OPT_FLAGS
xpaint's debuginfo is empty, pdfconcat not built with $RPM_OPT_FLAGS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xpaint (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Paulo Roma Cavalcanti
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2009-11-22 14:42 EST by Ville Skyttä
Modified: 2010-01-30 07:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-30 07:28:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2009-11-22 14:42:57 EST
xpaint-debuginfo-2.8.7.3-1.fc13.x86_64 is empty.  Additionally, pdfconcat is not built with $RPM_OPT_FLAGS:

http://kojipkgs.fedoraproject.org/packages/xpaint/2.8.7.3/1.fc13/data/logs/x86_64/build.log
+ gcc -O3 -s -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes -Wmissing-declarations pdfconcat.c -o pdfconcat

See the blocker bug for more info.
Comment 1 Fedora Update System 2010-01-29 10:31:23 EST
xpaint-2.8.13.1-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xpaint-2.8.13.1-1.fc11
Comment 2 Fedora Update System 2010-01-29 10:31:37 EST
xpaint-2.8.13.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xpaint-2.8.13.1-1.fc12
Comment 3 Paulo Roma Cavalcanti 2010-01-29 10:43:26 EST
I will remove the debug package in the next release, if it is still empty.

I also need to check why pdfconcat is not built with the appropriate flags.
Comment 4 Ville Skyttä 2010-01-29 11:05:57 EST
Do not remove it, fix it instead.  See compiler flags and debuginfo packages in packaging guidelines and bug 496968:
http://fedoraproject.org/wiki/Packaging/Guidelines#Compiler_flags

There are several reasons for it being empty already evident from briefly looking at the build log, in no particular order:

1) pdfconcat not built with $RPM_OPT_FLAGS (as already discussed)

2) pdfconcat installed with "install -s", the -s needs to be dropped:
install -c -s pdfconcat /builddir/build/BUILDROOT/xpaint-2.8.13.1-1.fc13.x86_64/usr/bin

3) /usr/bin/xpaint explicitly stripped during build, this needs to be removed:
strip /builddir/build/BUILDROOT/xpaint-2.8.13.1-1.fc13.x86_64/usr/bin/xpaint
Comment 5 Fedora Update System 2010-01-29 17:14:05 EST
xpaint-2.8.13.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xpaint-2.8.13.1-3.fc11
Comment 6 Fedora Update System 2010-01-29 17:14:19 EST
xpaint-2.8.13.1-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xpaint-2.8.13.1-3.fc12
Comment 7 Paulo Roma Cavalcanti 2010-01-30 07:28:47 EST
I am closing this bug, because it has been fixed in

xpaint-2.8.13.1-3.fc12

Note You need to log in before you can comment on or make changes to this bug.