Bug 54023 - unable to update kernel via up2date and beta.rhns.redhat.com
Summary: unable to update kernel via up2date and beta.rhns.redhat.com
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: roswell
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-25 17:44 UTC by nbardsley
Modified: 2015-01-07 23:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-01 19:29:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nbardsley 2001-09-25 17:44:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Using up2date to get 2.4.7-6 kernel results in a package conflict,
using beta.rhns.redhat.com to download a tarball gives a 404.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
A1.  remove kernel* from pkgSkipList
A2.  up2date --nox --download --update --test

B1.  select all 6 kernel packages on beta.rhns.redhat.com
B2.  click download selected packages
B3.  select i686 arch
B4.  click download selected packages


Actual Results:  A.  RPM conflict error.  The message was:
Test install failed because of package conflicts:
file /boot/System.map-2.4.7-6 conflicts between attempted installs of 
kernel-2.4.7-6 and kernel-2.4.7-6

B.  404 Error - File not found

Expected Results:  A.  rpms downloaded
B.  tarball downloaded

Additional info:

B.  same error occurs even with only one file that does not have multiple 
arches, such as kernel-source

=ALL= other packages are current, via up2date.
[root@chopin rhn]# rpm -q up2date
up2date-2.6.0-7.x.37

Comment 1 Adrian Likins 2001-10-01 19:28:59 UTC
This has been fixed in the most recent versions of the client.

Basically, the package arch handling was broken, and has since been
fixed.

Comment 2 Jay Turner 2001-10-02 13:34:16 UTC
Fixed in the latest code.   Closing out.


Note You need to log in before you can comment on or make changes to this bug.