Bug 540308 - [abrt] crash detected in gnome-screensaver-2.28.0-6.fc12 (BadDrawable)
[abrt] crash detected in gnome-screensaver-2.28.0-6.fc12 (BadDrawable)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:4299ed1141dbc35e57b7696728d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-22 20:02 EST by Zhang Huan
Modified: 2009-12-17 23:46 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.18.5-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-17 23:46:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (12.15 KB, text/plain)
2009-11-22 20:02 EST, Zhang Huan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 598476 None None None Never

  None (edit)
Description Zhang Huan 2009-11-22 20:02:00 EST
abrt detected a crash.

Attached file: backtrace
cmdline: gnome-screensaver
component: gnome-screensaver
executable: /usr/bin/gnome-screensaver
kernel: 2.6.31.5-127.fc12.x86_64
package: gnome-screensaver-2.28.0-6.fc12
rating: 4
reason: Process was terminated by signal 6
Comment 1 Zhang Huan 2009-11-22 20:02:03 EST
Created attachment 372991 [details]
File: backtrace
Comment 2 Ray Strode [halfline] 2009-12-02 13:16:13 EST
were you doing anything specifically when this crash happened?
Comment 3 Dams 2009-12-02 15:06:31 EST
Nope. I've left the PC for the night. 
IIRC there was gnome, evolution, OOo, ffox and gnome-terminal running. 
Nothing more. Before you ask, there was enough ram and no OOM message in dmesg.
Comment 4 Michal Schmidt 2009-12-03 13:31:46 EST
This was reported to me by a user in a Jabber MUC and I could reproduce it.

It is not reproducible reliably, but it happened more than once to me.
1. Configure the Gnome screensaver to Blank screen
2. In Gnome main menu: System -> Lock screen
3. When the screen blanks, move the mouse.
4. In the password dialog press Cancel.

Locking the session is ineffective if the screensaver can be crashed by cancelling the password entry dialog :-)
[Increasing Severity to High]

When the screensaver dies, .xsession-errors contains:

Gdk-ERROR **: The program 'gnome-screensaver' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2158 error_code 9 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
gnome-session[1920]: WARNING: Detected that screensaver has left the bus
Comment 5 Ray Strode [halfline] 2009-12-03 16:51:13 EST
We should get an update out for this asap.
Comment 6 Ray Strode [halfline] 2009-12-08 12:05:40 EST
So I looked into this a bit (see gnome bug 598476) and it turns out this is a gtk issue.  Alex did a patch, mclasen commited it.

Moving to gtk+
Comment 7 Fedora Update System 2009-12-08 12:13:51 EST
gtk2-2.18.5-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gtk2-2.18.5-3.fc12
Comment 9 Fedora Update System 2009-12-09 23:10:35 EST
gtk2-2.18.5-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12950
Comment 10 Fedora Update System 2009-12-17 23:46:16 EST
gtk2-2.18.5-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.