Bug 54038 - 'Could not allocate partitions' error or crash from kickstart
'Could not allocate partitions' error or crash from kickstart
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-26 07:26 EDT by Jure Pecar
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-26 07:26:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jure Pecar 2001-09-26 07:26:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
I'm trying to install roswell (7.1.94) with kickstart on a test machine. It
always bombs out on creating partitions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
No special steps needed ... just a normal kickstart setup & install.
happens every time on this box. Haven't managed to make it install yet ...
RedHat 7.0 kickstart works ok.

Actual Results:  There are several variations of what i tried:
1. Empty disk (no partitions), zerombr yes and clearpart --all --initlabel
in ks.cfg: i get the 'Could not allocate requested partitions: Partitioning
failed: Could not allocate partitions. Press OK to reboot your system.'
error.
2. Hand made partitions, zerombr and clearpart commented out in ks.cfg:
anaconda crashes with 'TypeError: number coercion failed.'

Expected Results:  Well, it should work, no? :)

Additional info:

I sent a mail to kickstart list with attached anaconda dump output. See
http://www.redhat.com/mailing-lists/kickstart-list/msg00947.html .

I tried various options for partitioning in ks.cfg with no success. Is the
order of statements important in ks.cfg?

Manual instalation of roswell on this box works ok. So I ran ksconfig and
used its output for my ks.cfg. Got the same error.

HW info: p3 800, intel 815eea board, 256mb ram, one seagate ATA100 10gb ide
disk on hda, ide cdrom on hdc.

Full ks.cfg:
--
lang en_US

network --bootproto dhcp

nfs --server my.nfs.server --dir /data/roswell

bootloader --location=mbr --md5pass=mymd5passstring
zerombr yes
clearpart --linux
part /boot --size 64
part swap --size 512
part / --grow

mouse generic3ps/2
timezone Europe/Ljubljana
langsupport --default en_US sl_SI
keyboard us
text
install 
firewall --disabled

xconfig --card --monitor --defaultdesktop=KDE --startxonboot --resolution
1280x1024 --depth 16

rootpw --iscrypted mycryptpassstring

auth --useshadow --enablemd5 --enableldap --enableldapauth
--ldapserver=my.ldap.server --ldapbasedn="mybasedn" --enablecache

reboot

%packages
@ X Window System
@ KDE
@ DOS/Windows Connectivity
@ Graphics Manipulation
@ Games
@ Multimedia Support
@ Networked Workstation
@ Utilities
@ Development
Comment 1 Jeremy Katz 2001-09-26 12:30:30 EDT
You're missing an initial size specification for the root partition... use
something like

part / --size 500 --grow

and it will work.  CVS has a better check for this and gives a somewhat better
error.

Note You need to log in before you can comment on or make changes to this bug.