Bug 54044 - new POP3 DoS
Summary: new POP3 DoS
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: inetd   
(Show other bugs)
Version: 6.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-26 15:51 UTC by Graham Houston
Modified: 2007-04-18 16:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-21 16:04:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Graham Houston 2001-09-26 15:51:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
after installing imap-2000c-1.6.0 and related packages I discovered pop3 
v2000.70rh crashes when it reaches it's default inetd.conf limit

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.connect to port 110 41 times very quickly
2.
3.
	

Actual Results:  pop3 falls over and needs a restart

Expected Results:  should not spawn another pop as its maxed out.

Additional info:

quick kludge fix alter this line in /etc/inetd.conf

pop-3   stream  tcp     nowait  root    /usr/sbin/tcpd    ipop3d  

to:

pop-3   stream  tcp     nowait.1024  root    /usr/sbin/tcpd     ipop3d

Comment 1 Mike A. Harris 2001-11-20 11:35:48 UTC
That would IMHO be an inetd problem, as inetd spawns imap.

Comment 2 Graham Houston 2001-11-20 15:00:04 UTC
My server is using inetd-0.16-7, I think this is the latest version from RH?



Comment 3 Trond Eivind Glomsrxd 2001-11-20 15:49:24 UTC
RHL 6.2 uses inetd, not xinetd - assigning back.

Comment 4 Jeff Johnson 2001-11-20 16:00:59 UTC
Pong. I don't own inetd anymore, no matter what bugzilla thinks.
Please find some other means to resolve this problem.

Comment 5 Trond Eivind Glomsrxd 2001-11-20 16:04:06 UTC
You can reassign owner without changing to the wrong component.

Comment 6 Jeff Johnson 2001-11-20 16:11:03 UTC
That presumes that I know who the appropriate owner
is, a context which I do not have.

Instead I've chosen to assign to the owner of the closest related
package in the hopes that their context and knowledge is superior
to my own.

Comment 7 Mike A. Harris 2001-11-21 01:20:14 UTC
pts/5 mharris@porkchop:~$ who-owns inetd
devel_orphan@redhat.com

Probably this should be brought up on an internal mailing list for
discussion then.  Someone should look into it, and inetd should be
assigned to someone.  It isn't a good idea for any package to be
an orphan.

Comment 8 Trond Eivind Glomsrxd 2001-11-21 16:04:34 UTC
If imap/pop crashes, it would be an imap issue. If it is just  the system being
overloaded by many connects, it would be a local configuration issue (add the
maxconnect specifier suggested by the reporter). Mike, does imap/pop really crash?

Comment 9 Trond Eivind Glomsrxd 2002-07-25 22:47:39 UTC
Closing due to lack of feedback.


Note You need to log in before you can comment on or make changes to this bug.