Bug 540482 - PK-Command Not Found run program after installation which can't be stopped with control c
Summary: PK-Command Not Found run program after installation which can't be stopped wi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 548739 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-23 14:00 UTC by Matej Nemcek
Modified: 2009-12-27 20:28 UTC (History)
3 users (show)

Fixed In Version: 2.28.3-0.1.20091211git.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-23 14:51:40 UTC
Type: ---


Attachments (Terms of Use)

Description Matej Nemcek 2009-11-23 14:00:23 UTC
Description of problem:
PackageKit Command Not Found after installation of new command it starts it in loop and won't quit it ^c. 

Version-Release number of selected component (if applicable):


How reproducible:
Agree with installation of command which doesn't exist on the host.

Steps to Reproduce:
1.ifstat (fox example)
2.y
3.^c
  
Actual results:
[wao@localhost ~]$ ifstat
Command not found. Install package 'ifstat' to provide command 'ifstat'? [N/y] 
 * Installing packages.. 
 * Getting information.. 
 * Resolving dependencies.. 
 * Waiting for authentication.. 
 * Resolving dependencies.. 
 * Downloading packages.. 
 * Testing changes.. 
 * Installing packages.. 
 * Scanning applications..        eth0                br0        
 KB/s in  KB/s out   KB/s in  KB/s out
[wao@localhost ~]$     0.00      0.00      0.00      0.00
    0.00      0.00      0.00      0.00
    0.00      0.00      0.00      0.00
    0.06      0.05      0.04      0.05
^C
[wao@localhost ~]$     0.00      0.00      0.00      0.00
    0.06      0.05      0.04      0.05
^C
[wao@localhost ~]$     0.00      0.00      0.00      0.00
    0.00      0.00      0.00      0.00
    0.00      0.00      0.00      0.00
^C
[wao@localhost ~]$     0.00      0.00      0.00      0.00
    0.00      0.00      0.00      0.00


Expected results:
[wao@localhost ~]$ ifstat
Command not found. Install package 'ifstat' to provide command 'ifstat'? [N/y] 
 * Installing packages.. 
 * Getting information.. 
 * Resolving dependencies.. 
 * Waiting for authentication.. 
 * Resolving dependencies.. 
 * Downloading packages.. 
 * Testing changes.. 
 * Installing packages.. 
 * Scanning applications..        eth0                br0        
 KB/s in  KB/s out   KB/s in  KB/s out
[wao@localhost ~]$     0.00      0.00      0.00      0.00
    0.00      0.00      0.00      0.00
    0.00      0.00      0.00      0.00
    0.06      0.05      0.04      0.05
^C
[wao@localhost ~]$

Additional info:

Comment 1 Richard Hughes 2009-11-23 14:17:07 UTC
What version PackageKit?

Comment 2 Matej Nemcek 2009-11-23 14:28:37 UTC
PackageKit-command-not-found-0.5.4-0.3.20091029git.fc12.i686

Comment 3 Richard Hughes 2009-11-23 14:51:40 UTC
commit 9c51a626a929889e29af6d66cccba67e42138822
Author: Richard Hughes <richard@hughsie.com>
Date:   Mon Nov 23 14:50:45 2009 +0000

    cnf: Run the newly installed file sync so we can return a proper exit code. Fixes rh#540482

Comment 4 Fedora Update System 2009-12-07 16:30:41 UTC
PackageKit-0.5.5-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/PackageKit-0.5.5-1.fc12

Comment 5 Fedora Update System 2009-12-18 13:30:02 UTC
gnome-packagekit-2.28.3-0.1.20091211git.fc12,kpackagekit-0.5.2-1.fc12,PackageKit-0.5.5-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnome-packagekit-2.28.3-0.1.20091211git.fc12,kpackagekit-0.5.2-1.fc12,PackageKit-0.5.5-1.fc12

Comment 6 Richard Hughes 2009-12-18 13:40:31 UTC
*** Bug 548739 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2009-12-27 20:27:53 UTC
gnome-packagekit-2.28.3-0.1.20091211git.fc12, kpackagekit-0.5.2-1.fc12, PackageKit-0.5.5-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.