Bug 540512 - Eclipse with Java EE plugin doesn't allow Dynamic Web Module version 2.5 (nullpointerexception)
Eclipse with Java EE plugin doesn't allow Dynamic Web Module version 2.5 (nul...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-23 09:56 EST by Tim Peters
Modified: 2009-11-23 15:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-23 15:53:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Peters 2009-11-23 09:56:14 EST
Description of problem:
i can't create a new Dynamic Web project, with Dynamic web module version set to '2.5'. you can create the project as normal, but when you click finish, it gives an nullpointerexception saying: Failed when installing Dynamic Web Module 2.5.


Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. install the JAVA EE plugin
2. create a new dynamic web project
3. set 'dynamic web module version' to 2.5
4. click version
  
Actual results:
nullpointerexception, project is not complete (not a web project)

Expected results:
no error, good, working, project

Additional info:
Comment 1 Andrew Overholt 2009-11-23 09:59:19 EST
I wonder if "installing Dynamic Web Module 2.5" means "try to copy files to a read-only location as a non-root user.
Comment 2 Tim Peters 2009-11-23 10:13:42 EST
it think it means that it cannot find the 2.5 libraries
Comment 3 Andrew Overholt 2009-11-23 10:21:42 EST
We'll have to try to figure out what it's trying to do.  Where is it expecting to get said libraries?  Where is it trying to put said libraries?
Comment 4 Tim Peters 2009-11-23 10:28:44 EST
it's not copying anything, as far as i can tell, it adds the said libraries to the class path (.classpath), and sets the version number in: .settings/org.eclipse.wst.common.project.facet.core.xml (in the project)
i don't know how eclipse uses it with compiling, and where it tried to get it's libraries from. i DO know that it works in the version downloaded from the eclipse website.
Comment 5 Andrew Overholt 2009-11-23 10:37:51 EST
It would help to track this down if you tried the following:

$ mv ~/.eclipse{,.bak20091123}
$ su -
# tar zxf <upstream tarball> /usr/local
# exit
$ /usr/local/eclipse/eclipse -data /tmp/testWorkspace

Then try installing WTP just like you did with the RPM-installed version.  Does it fail in the same manner?  Does it work?

Thanks.
Comment 6 Tim Peters 2009-11-23 10:52:09 EST
i tried what you said, and i'm getting the same error using the upstream version, with java EE installed seperately.
Comment 7 Andrew Overholt 2009-11-23 11:02:20 EST
Okay, good.  (Well, not good for you, Tim, but good that it's not something we've broken in the RPMs :).

At this point, it'd be best to file a bug with WTP saying something to the effect of "dynamic web project doesn't work with read-only installation".
Comment 8 Tim Peters 2009-11-23 11:10:49 EST
haha, ok. i'll file a bug there then
Comment 9 Tim Peters 2009-11-23 15:53:04 EST
i installed 'JST Web UI' and 'JST Server UI' that seemed to have fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.