Bug 540599 - Cannot upgrade from F11 to F12 because of not enough free space in /boot
Cannot upgrade from F11 to F12 because of not enough free space in /boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-23 14:02 EST by Pieter de Rijk
Modified: 2014-01-21 18:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 06:46:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pieter de Rijk 2009-11-23 14:02:36 EST
Description of problem:
Pre-upgrade F11 to F12 doesn't check freespace in /boot 

Version-Release number of selected component (if applicable):
preupgrade-1.1.2-1.fc11.noarch.rpm

How reproducible:


Steps to Reproduce:
1. Have an F11 install (with default disklayout), install and run preupgrade to F12;
2. Reboot and select the entry "Upgrade to Fedora 12 (Constantine)"
  
Actual results:
Anaconda complains about not enough free-space in /boot

Expected results:
Continue upgrading system and 'clean' up /boot to free up enough space during preupgrade or during kickstart.

Additional info:
Did used the recommended size for /boot during F11 install. Applies on i686 and x86_64.
Comment 1 Hans de Goede 2009-12-02 05:32:46 EST
On your first attempted upgrade, did anaconda start to install packages, and then fail because it ran out of space, or did it just tell you you did not have enough space ?

Did you free the space while running the installer, or did you reboot back
into F-11, and how exactly did you free the space ?

If you freed the space under the installer, did you do so before anaconda complained about lack of space, or did you go back after the complaint, freed the space and tried again ?

Can you please get the anaconda log files from /var/log (on your currently running system) and attach them here ?
Comment 2 Hans de Goede 2009-12-02 06:46:32 EST
Sorry comment #1 should have gone to bug 540602.

About this bug, yes the pre-upgrade failing due to /boot being to small, this is a known issue. We've made the default /boot size for F-12 larger to avoid this. 

I know this won't help users who upgraded from F-11 or older as they are stuck with the old /boot size. We are trying to see if we can do something for these users. But for now the advise is to use another update method (such as using the installation dvd to upgrade).

Note You need to log in before you can comment on or make changes to this bug.