Bug 540620 - multilib conflict on /usr/bin/cups-config
multilib conflict on /usr/bin/cups-config
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
: 550603 (view as bug list)
Depends On: 544391
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-23 14:58 EST by Edward Sheldrake
Modified: 2010-03-12 21:29 EST (History)
6 users (show)

See Also:
Fixed In Version: cups-1.4.2-26.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-12 21:29:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Sheldrake 2009-11-23 14:58:12 EST
Description of problem:
file /usr/bin/cups-config conflicts between attempted installs of cups-devel-1:1.4.2-7.fc12.x86_64 and cups-devel-1:1.4.2-7.fc12.i686

Version-Release number of selected component (if applicable):
cups-devel-1.4.2-7.fc12

How reproducible:
Always

Steps to Reproduce:
1. Try to install cups-devel i686 and x86_64 rpms
2.
3.
  
Actual results:
Conflict on /usr/bin/cups-config

Expected results:
No conflict

Additional info:
"cups-config --libs" output:

-lcups -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fstack-protector-all -DLDAP_DEPRECATED=1 -I/usr/include/dbus-1.0 -I64/dbus-1.0/include -DDBUS_API_SUBJECT_TO_CHANGE -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lz -lpthread -lm -lcrypt

It's got all the CFLAGS. A config.log I created has the CFLAGS as part of LIBGSSAPI.
Comment 1 Edward Sheldrake 2009-11-23 16:09:16 EST
I think this may be due to Fedora 12's krb5-config script, because Fedora 11 didn't have this problem.

Fedora 11 krb5-config had:
CC_LINK='$(CC) $(PROG_LIBPATH)'

Fedora 12 krb5-config has:
CC_LINK='$(CC) $(PROG_LIBPATH) $(PROG_RPATH_FLAGS) $(CFLAGS) -pie $(LDFLAGS)'
Comment 2 Alex Villacís Lasso 2009-12-10 17:55:44 EST
This bug is confirmed in my setup. In addition, this bug prevents me from setting up a 32-bit library environment on my 64-bit Fedora 12 for compiling Wine from sources.
Comment 3 Jiri Popelka 2009-12-27 05:45:51 EST
*** Bug 550603 has been marked as a duplicate of this bug. ***
Comment 4 Tim Waugh 2010-01-14 07:44:14 EST
Fixed by rebuilding against newer krb5.
Comment 6 Fedora Update System 2010-02-23 07:47:17 EST
cups-1.4.2-23.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cups-1.4.2-23.fc11
Comment 7 Fedora Update System 2010-02-23 07:48:53 EST
cups-1.4.2-23.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cups-1.4.2-23.fc11
Comment 8 Fedora Update System 2010-02-23 07:50:26 EST
cups-1.4.2-25.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/cups-1.4.2-25.fc12
Comment 9 Fedora Update System 2010-02-23 07:51:12 EST
cups-1.4.2-25.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/cups-1.4.2-25.fc12
Comment 10 Fedora Update System 2010-02-23 07:52:26 EST
cups-1.4.2-31.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/cups-1.4.2-31.fc13
Comment 11 Fedora Update System 2010-02-23 07:57:57 EST
cups-1.4.2-25.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/cups-1.4.2-25.fc12
Comment 12 Fedora Update System 2010-02-23 11:08:04 EST
cups-1.4.2-31.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2681
Comment 13 Fedora Update System 2010-02-24 01:11:35 EST
cups-1.4.2-23.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-2743
Comment 14 Fedora Update System 2010-02-24 01:12:07 EST
cups-1.4.2-25.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-2748
Comment 15 Alex Villacís Lasso 2010-02-24 11:51:59 EST
Tested cups-1.4.2-25.fc12 on Fedora 12 x86_64. It seems the problem is now solved.
Comment 16 Fedora Update System 2010-02-28 09:46:54 EST
cups-1.4.2-31.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2010-03-05 22:54:12 EST
cups-1.4.2-26.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/cups-1.4.2-26.fc11
Comment 18 Fedora Update System 2010-03-12 21:28:34 EST
cups-1.4.2-26.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.