Bug 54072 - Connection rejection leads to hosed system
Summary: Connection rejection leads to hosed system
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-26 20:52 UTC by Bertil Askelid
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-26 20:52:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bertil Askelid 2001-09-26 20:52:33 UTC
Description of Problem:

For some unknown reason, sendmail occasionally (days weeks in between)
starts to reject connections:

	Sep 25 19:45:42 pop sendmail[23360]: rejecting connections on       
   	daemon MTA: load average: 12

I have a standard sendmail configuration as it comes from Red Hat. Sendmail
only listens to the localhost interface. Besides, my ipchains blocks any
access from the outside.

The rejections continue and after a couple of hours, the system is hosed:

	Sep 25 22:23:37 pop sendmail[23360]: runqueue: Skipping queue run
	-- load average too high
	Sep 25 22:23:42 pop sendmail[23360]: rejecting connections on
	daemon MTA: load average: 83

Unable to create new processes, so only way out is a power cycled reboot.

Version-Release number of selected component (if applicable):

	sendmail-8.11.6-1.7.1

How Reproducible:

	Random

Steps to Reproduce:
1. Don't know
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Florian La Roche 2001-12-08 09:46:45 UTC
There is a load limit and sendmail won't accept/deliver email if it is
too high. So looks like normal behaviour.

Florian La Roche


Comment 2 Bertil Askelid 2001-12-08 15:26:08 UTC
How can the load limit be reached when my system is under no load at all. No
emails being handled except for maybe 1 or 2 an hour? This is a home system with
just a very few users. And sendmail is not accessible for email reception from
the outside as all outside connections are firewalled. I use POP to fetch
emails.

Please explain!


Note You need to log in before you can comment on or make changes to this bug.