Bug 54079 - 7.1 doesn't work with the Promise Ultra100TX2 card
7.1 doesn't work with the Promise Ultra100TX2 card
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-26 19:02 EDT by Richard Gugeler
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:11:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Promise document: Using Ultra100TX2 with Linux (2.37 KB, text/plain)
2001-09-27 14:38 EDT, Richard Gugeler
no flags Details

  None (edit)
Description Richard Gugeler 2001-09-26 19:02:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I successfully installed 7.1 from the Deluxe Workstation boxed set while 
my drive was connected to the primary onboard IDE controller (hda).  When 
I installed the Promise Ultra100TX2 IDE controller and tried to start 
Linux, the process always terminates with a Kernel panic message.  Since I 
use a start-up diskette, I can get to a "boot:" prompt and have tried 
several methods to get around the problem.  None worked, including "linux 
ide2=noautotune", "linux nodma", "linux ide2=0x10d0,0x10c6" and "linux 
append root=/dev/hde7".  (If it makes a difference, quote marks were not 
typed.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attach hard drive to Promise Ultra100TX2 controller.
2. Turn on computer.
3. Boot using start-up disk.
	

Actual Results:  Process stops with a Kernel panic message.

Expected Results:  Should have started Linux.

Additional info:

WD400 drive partitioned for Win98, Win2k Server (not yet installed) and 
Linux 7.1.  Linux partitions are hda2 (/boot, 1Gb), hda7 (/root, 4Gb) and 
hda8 (SWAP, 1Gb).

Promise says the card works with Linux, but perhaps an earlier version.

Also:  If you try to start the system with the drive connected to the 
Promise card and the Linux 7.1 CD1 in the CD-ROM drive, the system goes 
through its memory check, locates the attached components and then the 
Promise card looks for any attached drives.  When this happens, you can 
hear the CD-ROM drive spin up.  The process ends with a "Boot error" 
message every time.  I get the impression that the Linux installation 
program tries to launch while the Promise card is doing its check and 
fails.
Comment 1 Richard Gugeler 2001-09-27 14:38:54 EDT
Created attachment 32798 [details]
Promise document: Using Ultra100TX2 with Linux
Comment 2 Richard Gugeler 2001-09-27 14:43:00 EDT
[This may be a duplicate since I'm not sure what happened to this field when I 
submitted the attachment.]  I had installed 7.1 when the drive had been 
connected to the onboard Primary Master IDE controller (hda). Then when I 
installed the Promise card, I could not get Linux to start. (Note that I was 
using the startup disk created when I installed 7.1.) To make a long story 
short, the correct command to use (for my system) at the "boot:" prompt 
presented by the startup disk is: "linux ide2=0x10d0,0x10c6 root=/dev/hde7" Do 
not use any quote marks. I then edited /etc/fstab to point "swap" to /dev/hde8 
(instead of /dev/hda8). Finally, to automate the boot process, I changed 
the "append" line in syslinux.cfg (on the startup diskette) to read (without 
the quotes, of course) "append initrd=initrd.img root=/dev/hde7 
ide2=0x10d0,0x10c6 ide3=0x10c8,0x10c2"
  
The information about the "ide2=0x...." command was provided in a document from 
Promise (sent as an attachment).  Note that, if you're trying to install Linux 
for the first time, you cannot boot from the CD ROM. The Promise controller 
seems to conflict with the boot process and everything terminates with a "Boot 
error" message. However, I suspect you can create the boot disk as described in 
the Installation Guide, issue the correct commands, and proceed with the 
installation.
Comment 3 Brent Fox 2001-10-16 15:42:54 EDT
I'm going to change the component to the kernel since you are seeing a kernel panic.
Comment 4 Arjan van de Ven 2001-10-16 15:45:30 EDT
Any text in the panic that might give a hint on what is happening ?
What's the last thing before the panic ?
Comment 5 Richard Gugeler 2001-10-16 18:47:08 EDT
As I reported, I do have everything working fine;  it just required some 
tweaking by hand since the card isn't supported directly.

Do you want me to recreate the conditions which caused the kernel panic 
message?  (Not a problem if I boot using a diskette.)  If so, how much of the 
text before the kernel panic notice do you want?  Anything in particular?  Are 
the messages displayed during the boot process saved in a file I can send to 
you?

Note You need to log in before you can comment on or make changes to this bug.