Bug 54088 - pppd 2.4.0 does not work with Ericsson r520m/t39m GPRS phones
pppd 2.4.0 does not work with Ericsson r520m/t39m GPRS phones
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-27 06:17 EDT by Mikko Rapeli
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikko Rapeli 2001-09-27 06:17:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
My scripts for Ericsson GPRS phones 
(www.iki.fi/mikko.rapeli/linux_gprs.html) work fine with Redhat 6.0 and 
6.2 pppd's (e.g. pppd 2.3.10), but on 7.0 and 7.1 the pppd 2.4.0 IPCP 
negotiations don't work for some odd reason. A friend of mine upgraded the 
pppd to 2.4.1 from a source package and the problem was fixed. Please put 
a newer version of pppd to your distributions.

Version-Release number of selected component (if applicable): pppd 2.4.0


How reproducible:
Always

Steps to Reproduce:
1. Install my scripts from http://www.iki.fi/mikko.rapeli/linux_gprs.html, 
and buy an Ericsson GPRS phone ;)
2. Try to use them with pppd 2.4.0, which comes with RH7.1 for example
3.

Actual Results:  IPCP negotiations hung

Expected Results:  Peer IP address negotiations should succeed

Additional info:
Comment 1 Thomas Woerner 2004-08-13 05:30:28 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.