This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 540912 - UI issue when cloning virtual machine
UI issue when cloning virtual machine
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2009-11-24 09:10 EST by Tim Waugh
Modified: 2010-01-04 15:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-04 15:02:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2009-11-24 09:10:15 EST
Description of problem:
When trying to specify the filename of the storage for a cloned machine the UI shows incorrectly.

Version-Release number of selected component (if applicable):
virt-manager-0.8.0-7.fc12.noarch

How reproducible:
100%

Steps to Reproduce:
1.Set up a virtual machine with storage from an already-existing file in the filesystem
2.Right-click on the machine and select Clone
3.In the 'Storage' part of the dialog, click the drop-down that says "Share disk with ..." and change it to "Details..."
4.Select 'Create a new disk (clone) for the virtual machine'
5.Choose a filename
6.Click OK

Actual results:
The drop-down says 'Share disk with ...' again.

Additional info:
Creating the clone ends up with storage that is shared with the original machine.
Comment 1 Cole Robinson 2009-12-01 20:45:15 EST
Hmm, I can't reproduce. Can you provide:

~/.virt-manager/virt-manager.log (after the steps above)
virsh dumpxml <vmname>

Is the VM running when you select 'clone'?
Comment 2 Cole Robinson 2009-12-01 22:01:18 EST
Nevermind, I reproduced. Fixed now:

http://hg.fedorahosted.org/hg/virt-manager/rev/2a67823d6e71
Comment 3 Fedora Update System 2009-12-03 18:47:49 EST
virt-manager-0.8.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/virt-manager-0.8.1-1.fc12
Comment 4 Fedora Update System 2009-12-04 18:35:00 EST
virt-manager-0.8.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12603
Comment 5 Cole Robinson 2010-01-04 15:02:52 EST
Fixed in virt-manager-0.8.2-1.fc12, now in stable.

Note You need to log in before you can comment on or make changes to this bug.