This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 54092 - crash when opening ftp.kernel.org
crash when opening ftp.kernel.org
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: ncftp (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-27 08:27 EDT by Kjartan Maraas
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-22 11:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2001-09-27 08:27:08 EDT
Description of Problem:

I get this crash when trying to open ftp.kernel.org

Version-Release number of selected component (if applicable):


How Reproducible:

Every time

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:


Crash:

#0  0x40120584 in __libc_write () from /lib/i686/libc.so.6
#1  0x40176154 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x400bc4f9 in new_do_write (fp=0x8092698, 
    data=0x401a7000 "PWD\r\nkmaraas@km-lt.bfe.oslo.kommune.no\r\n", to_do=5)
    at fileops.c:464
#3  0x400bb64c in _IO_new_file_overflow (f=0x8092698, ch=-1) at fileops.c:438
#4  0x400bbd2e in _IO_new_file_xsputn (f=0x8092698, data=0xbfffeae0, n=5)
    at fileops.c:962
#5  0x400b1b2e in _IO_fputs (str=0xbfffeae0 "PWD\r\n", fp=0x8092698)
    at iofputs.c:40
#6  0x0806257d in getline ()
#7  0x080628e3 in getline ()
#8  0x0805eef5 in getline ()
#9  0x0805d390 in getline ()
#10 0x0805e2fb in getline ()
#11 0x0804d9be in strcpy ()
#12 0x0804e152 in strcpy ()
#13 0x080521c7 in strcpy ()
#14 0x080524fd in strcpy ()
#15 0x08051c3e in strcpy ()
#16 0x4005c507 in __libc_start_main (main=0x8051ab0 <strcpy+30704>, argc=1, 
    ubp_av=0xbffff914, init=0x80499f8, fini=0x806cea0 <__divdi3+464>, 
    rtld_fini=0x4000dc14 <_dl_fini>, stack_end=0xbffff90c)
Comment 1 Bernhard Rosenkraenzer 2001-09-27 12:04:09 EDT
Works for me... Any odd firewall settings, proxies, IPv6 tunnels or the likes?
Comment 2 Bernhard Rosenkraenzer 2001-09-27 12:05:56 EDT
The backtrace looks a lot like memory corruption... There's no reason 
whatsoever why an ftp client would issue commands

PWD
your@address

in that order. (Expected:
USER ftp
PASS you@address
PWD
)

Comment 3 Kjartan Maraas 2001-09-28 04:44:33 EDT
No proxy, not sure about firewalls as I'm at a conference. There seems to be
nothing special about things here. I still see this after a reboot and with the
latest kernel from the beta rawhide.
Comment 4 Pekka Savola 2002-06-22 11:21:47 EDT
This isn't related to now-fixed #47763 probably?

(At least, I'd check a bit with tcpdump.)
Comment 5 Kjartan Maraas 2002-06-23 07:30:53 EDT
Never seen it again. Closing.

Note You need to log in before you can comment on or make changes to this bug.