Bug 54093 - add command line flag to *not* start pxe as a daemon
Summary: add command line flag to *not* start pxe as a daemon
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pxe (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-27 13:29 UTC by bruno
Modified: 2007-03-27 03:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 10:55:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bruno 2001-09-27 13:29:57 UTC
we'd like to see a flag added to the pxe server so it can run in the
foreground.


Version-Release number of selected component (if applicable):
pxe-0.1-23


Additional info:
we'd like to use the pxe server with xinetd.

since pxe immediately daemonizes itself after xinetd starts it, xinetd
thinks pxe has failed and will soon disable the service. also, daemonizing
doesn't allow xinetd to control the number of pxe instances currently
running.

Comment 1 Elliot Lee 2002-08-13 19:35:20 UTC
It appears that pxe is not run out of xinetd anymore, so your wish was granted at some 
point.


Note You need to log in before you can comment on or make changes to this bug.