Bug 540955 - pahole doesn't work on F12
Summary: pahole doesn't work on F12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dwarves
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Arnaldo Carvalho de Melo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-24 15:08 UTC by Mike Snitzer
Modified: 2009-12-08 07:43 UTC (History)
1 user (show)

Fixed In Version: 1.8-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-08 07:43:08 UTC
Type: ---


Attachments (Terms of Use)
fix for pahole BRAIN FART ALERTs on F12 (794 bytes, patch)
2009-11-24 15:11 UTC, Mike Snitzer
no flags Details | Diff

Description Mike Snitzer 2009-11-24 15:08:12 UTC
Description of problem:
when I run pahole on F12 x86_64 I'm getting BRAIN
FART ALERTs (and other issues).

Version-Release number of selected component (if applicable):
dwarves-1.7-5.x86_64

How reproducible:
Always

Steps to Reproduce:
1. run pahole against the swiss_cheese example
2. see "BRAIN FART ALERT! ..."
  
Actual results:
$ pahole swiss_cheese
struct cheese {
        char                       name[17];             /*     0    17 */
        short int                  age;                  /*     0     2 */
        char                       type;                 /*     0     1 */
        int                        calories;             /*     0     4 */
        short int                  price;                /*     0     2 */
        int                        barcode[4];           /*     0    16 */

        /* size: 48, cachelines: 1, members: 6 */
        /* padding: 32 */
        /* last cacheline: 48 bytes */

        /* BRAIN FART ALERT! 48 != 17 + 0(holes), diff = 31 */

};

Expected results:
$ pahole swiss_cheese
struct cheese {
        char                       name[17];             /*     0    17 */

        /* XXX 1 byte hole, try to pack */

        short int                  age;                  /*    18     2 */
        char                       type;                 /*    20     1 */

        /* XXX 3 bytes hole, try to pack */

        int                        calories;             /*    24     4 */
        short int                  price;                /*    28     2 */

        /* XXX 2 bytes hole, try to pack */

        int                        barcode[4];           /*    32    16 */

        /* size: 48, cachelines: 1, members: 6 */
        /* sum members: 42, holes: 3, sum holes: 6 */
        /* last cacheline: 48 bytes */
};

Additional info:
I haven't attached the "swiss_cheese" example (which I got from acme's OLS 2007 "7 dwarves" paper) because acme has already given me a patch to test.  I verified that the patch (attached) fixes pahole on F12.

Comment 1 Mike Snitzer 2009-11-24 15:11:28 UTC
Created attachment 373463 [details]
fix for pahole BRAIN FART ALERTs on F12

Comment 2 Fedora Update System 2009-12-07 15:34:07 UTC
dwarves-1.8-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dwarves-1.8-1.fc12

Comment 3 Fedora Update System 2009-12-08 07:43:03 UTC
dwarves-1.8-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.