Bug 540956 - After upgrading from F11->F12, clicking on dialog buttons in Eclipse no longer works
After upgrading from F11->F12, clicking on dialog buttons in Eclipse no longe...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-24 10:08 EST by Dimi Paun
Modified: 2010-08-23 15:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 15:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dimi Paun 2009-11-24 10:08:32 EST
Description of problem:

My version of Eclipse (3.4.2) worked fine in F11 (using Sun't JVM 1.6.0 I believe). After upgrading to F12 (and switching to OpenJava java-1.6.0-openjdk-1.6.0.0-33.b16.fc12.i686), buttons in Eclipse dialogs no longer work correctly.

Namely, the push buttons (the Finish, Cancel, Back, Forward, etc) have a problem.
When clicked, they register the mouse down, they depress, etc, but when the mouse is released, they don't register the click. When moving the mouse around, they depress on hover, as if they still think the mouse button is down. Looks like the mouse up event is lost.

Pressing the accel key causes the action to be taken.
Comment 1 Alexander Kurtakov 2009-11-24 10:21:06 EST
Are you using eclipse downloaded from upstream?
The problem is fixed in Fedora's packages
Comment 2 Dimi Paun 2009-12-03 22:04:38 EST
Yes, I'm using the upstream eclipse. I've tried to use the one that comes with Fedora, but everytime something broke. 

I need to be able to use the upstream version. A few people I know are affected by this problem.
Comment 3 Andrew Overholt 2009-12-04 08:03:19 EST
(In reply to comment #2)
> Yes, I'm using the upstream eclipse. I've tried to use the one that comes with
> Fedora, but everytime something broke. 

It would great to hear what broke in separate bug reports.

> I need to be able to use the upstream version. A few people I know are affected
> by this problem.  

There are a bunch of bugs at bugs.eclipse.org.  Search for GTK2.18.  Try setting the environment variable GDK_NATIVE_WINDOWS=true before running eclipse.
Comment 4 Christof Damian 2009-12-04 08:54:30 EST
Same for Azureus by the way. Maybe this should be assigned to GTK
Comment 5 Andrew Overholt 2009-12-04 09:29:34 EST
It is indeed a GTK behavioural change but it's really an upstream issue.  Feel free to move this to GTK here in Red Hat bugzilla as we've worked around these issues in our Eclipse packages in Fedora.
Comment 6 Andrew Overholt 2010-08-23 15:41:32 EDT
Since this was fixed in our packages and was reported as an upstream issue, I'm going to close this bug.  Feel free to open a bug with GTK+.

Note You need to log in before you can comment on or make changes to this bug.