Bug 541026 - rb_libtorrent 0.14.6 crashes
Summary: rb_libtorrent 0.14.6 crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rb_libtorrent
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-24 19:04 UTC by Juan P. Daza P.
Modified: 2010-01-19 00:58 UTC (History)
1 user (show)

Fixed In Version: 0.14.8-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-19 00:58:16 UTC


Attachments (Terms of Use)

Description Juan P. Daza P. 2009-11-24 19:04:31 UTC
Description of problem:
There is an error in this library that returns an exception due to a problem in error handling when parsing torrent files.

Version-Release number of selected component (if applicable):
rb_libtorrent version 0.14.6

How reproducible:
Install this library to help testing qbittorent v.2.0.0 beta6.

Steps to Reproduce:
1. Install rb_libtorrent  0.14.6
2. Install qbittorent from (http://leigh123linux.fedorapeople.org/pub/rpm/12/qbittorrent_testing/x86_64/)
3. Use the program

Actual results:
Program crashes

Expected results:
Program woks

Additional info:
Reported to upstream: https://bugs.launchpad.net/qbittorrent/+bug/487308
they recommended to upgrade this library to 0.14.7.

Comment 1 Fedora Update System 2009-11-25 20:51:05 UTC
rb_libtorrent-0.14.7-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rb_libtorrent-0.14.7-1.fc12

Comment 2 Fedora Update System 2009-11-27 21:40:42 UTC
rb_libtorrent-0.14.7-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rb_libtorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12220

Comment 3 Juan P. Daza P. 2009-12-24 18:00:52 UTC
Christophe Dumez (qbittorrent author) has opened a bug in the rb_libtorrent bug system due to no answer was received from the authors by email:

http://code.google.com/p/libtorrent/issues/detail?id=3

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Fedora Update System 2010-01-14 01:20:13 UTC
rb_libtorrent-0.14.8-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rb_libtorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12220

Comment 5 Fedora Update System 2010-01-19 00:58:11 UTC
rb_libtorrent-0.14.8-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.