Bug 54104 - logic in ypinit is suspect
logic in ypinit is suspect
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-27 11:53 EDT by msterret
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-19 10:56:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes the logic in ypinit_master(); also makes the if statements consistent with the while statements; also, fixes some whitespace issues (2.75 KB, patch)
2001-09-27 11:55 EDT, msterret
no flags Details | Diff

  None (edit)
Description msterret 2001-09-27 11:53:30 EDT
Description of Problem: I don't think the code in ypinit does what the
programmer intended it to do.


Version-Release number of selected component (if applicable):
ypserv-1.3.12-2.src.rpm


How Reproducible: edit ypinit and look at the code


Steps to Reproduce:
1. vi /usr/lib/yp/ypinit
2. /Running^M (search for Running)
3. look at the code
Comment 1 msterret 2001-09-27 11:55:59 EDT
Created attachment 32738 [details]
fixes the logic in ypinit_master(); also makes the if statements consistent with the while statements; also, fixes some whitespace issues
Comment 2 msterret 2001-11-01 11:47:14 EST
Currently still broken in Red Hat Linux 7.2, but I don't see how to change
the Product and Version of a bug.
Comment 3 msterret 2001-11-01 11:52:15 EST
...sigh...figured it out as soon as I posted comment to the contrary, natch.
Comment 4 Alexander Larsson 2002-03-27 12:19:49 EST
This is fixed in 2.2. Upstream took your patch.

Note You need to log in before you can comment on or make changes to this bug.