Bug 54115 - Disk partitioning w/ Kickstart does not work
Disk partitioning w/ Kickstart does not work
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-27 13:18 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 13:18:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-27 13:18:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.2.17-14 i686)

Description of problem:
I have installed a machine from Roswell CDs just fine. I then took the
generated kickstart config file (in /root/), added my usual stuff to the
%post section and tried a Kickstart install of the very same machine. The
error popping up is:

Could not allocate requested partitions:
Partitioning failed: Could not allocate
partitions.

Here is the section from my ks.cfg file which is disk related:

zerombr yes
clearpart --all
part /               --fstype ext3 --size 2048
part swap                          --size 2048
part /var            --fstype ext3 --size 1024
part /usr/vice/cache --fstype ext3 --size 1024
part /tmp            --fstype ext3 --grow

There are no more information on the other virtual console windows.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make a ks.cfg with above mentioned disk partition schema
2. start Kickstart (I am using PXE and DHCP)
3.
	

Actual Results:  A window with above mentioned disk partition error pops
up.

Expected Results:  It should just partition the disk.

Additional info:
Comment 1 Jeremy Katz 2001-09-27 14:29:10 EDT
Specify a base size for the /tmp partition to grow from and it will work.  Dupe
of something else, current CVS gives a better error for this case
Comment 2 Need Real Name 2001-09-27 15:01:20 EDT
Ok, that works.
I would like to resubmit this as a documentation bug!
-- Alf.

Note You need to log in before you can comment on or make changes to this bug.