This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 541197 - Ibus crash
Ibus crash
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-25 03:05 EST by biAji
Modified: 2009-12-09 23:23 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2.0.20091204-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-09 23:23:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description biAji 2009-11-25 03:05:29 EST
Description of problem:

ibus crashed and can not using pinyin input method anymore. After restart ibus, it works again.

Version-Release number of selected component (if applicable):

ibus-1.2.0.20091024-1.fc12.i686
ibus-gtk-1.2.0.20091024-1.fc12.i686
ibus-pinyin-1.2.0.20090915-1.fc12.noarch


How reproducible:

Have no idea..happened randomly

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
things run smoothly

Additional info:

UUID: 08997608
architecture: i686
cmdline: python /usr/share/ibus/ui/gtk/main.py 
component: ibus
executable: /usr/share/ibus/ui/gtk/main.py
kernel: 2.6.31.5-127.fc12.i686
package: ibus-1.2.0.20091024-1.fc12
release: Fedora release 12 (Constantine)
uuid: 08997608

backtrace
-----
Summary: TB08997608 connection.py:630:call_blocking:DBusException: org.freedesktop.IBus.NoEngine: can not find engine with name pinyin

Traceback (most recent call last):
  File "/usr/share/ibus/ui/gtk/panel.py", line 425, in __im_menu_item_activate_cb
    self.__focus_ic.set_engine(engine)
  File "/usr/lib/python2.6/site-packages/ibus/inputcontext.py", line 238, in set_engine
    return self.__context.SetEngine(engine.name)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.IBus.NoEngine: can not find engine with name pinyin

Local variables in innermost frame:
byte_arrays: False
self: <dbus.connection.Connection object at 0x922256c>
args: (dbus.String(u'pinyin'),)
utf8_strings: False
bus_name: org.freedesktop.IBus
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: /org/freedesktop/IBus/InputContext_706
timeout: -1.0
signature: None
dbus_interface: None
message: <dbus.lowlevel.MethodCallMessage object at 0x9167ee0>
method: SetEngine
Comment 1 Peng Huang 2009-11-27 18:43:12 EST

*** This bug has been marked as a duplicate of bug 533640 ***
Comment 2 biAji 2009-11-28 01:58:34 EST
Why? Are you guys sure it's something about ibus-anthy??? 

I even not install ibus-anthy rpm package.  And fujiwara said it's nothing about it ..
Comment 3 Peng Huang 2009-11-29 18:45:34 EST
Sorry. It is a mistake.
This bug has been fixed in upstream. I will build it for fedora soon.
Comment 4 biAji 2009-11-29 20:19:21 EST
Thanks a lot phuang~  !
Comment 5 Fedora Update System 2009-12-04 04:08:30 EST
ibus-1.2.0.20091204-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ibus-1.2.0.20091204-1.fc12
Comment 6 Fedora Update System 2009-12-04 18:41:32 EST
ibus-1.2.0.20091204-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12644
Comment 7 Fedora Update System 2009-12-09 23:23:02 EST
ibus-1.2.0.20091204-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.