Bug 54122 - Disk Druid formats oversized swap partitions when they're created in fdisk
Disk Druid formats oversized swap partitions when they're created in fdisk
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-27 16:57 EDT by Zeke Harris
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zeke Harris 2001-09-27 16:57:29 EDT
Description of Problem:
When you make swap partitions in fdisk and then go into Disk Druid to
assign mount points, Disk Druid happily says "I found a swap partition!
Would you like me to format it for you?" and goes about doing just that --
no matter how large the swap partition is. For example, if one uses fdisk
to create an 8 gig swap partition, Disk Druid happily formats and uses it,
even though one could not create such a large swap partition in Disk Druid
alone.

Version-Release number of selected component (if applicable):


How Reproducible:
100%

Steps to Reproduce:
1. Use fdisk to create a >2GB swap partition
2. go into disk druid to assign mount points
3. click ok when prompted to format the swap partition

Actual Results:
Voila, one has a large swap partition.

Expected Results:
"I'm sorry, we're going to have to cut your slightly oversized swap
partition down to 2 gigs."

Additional Information:
Comment 1 Brent Fox 2001-09-28 11:56:48 EDT
I don't know, it may be better to say that we won't format a swap partition >
2GB.  They can go back into fdisk and fix it if they want to.  I'd be reluctant
to cut it down to 2GB without any sort of override from the user.  Perhaps we
could simply take the partition and cut it into 2GB slices.  That way, instead
of one 8GB swap, we'd slice it up into 4 2GB swap partitions.

katzj, what do you think?
Comment 2 Jeremy Katz 2001-09-28 12:11:30 EDT
I just asked Zeke to file it so that we could make sure and do something about
it for Hampton.  Really, it falls into the larger class of bugs called
"fdisk/disk druid don't interact well"
Comment 3 Michael Fulbright 2002-03-26 12:44:14 EST
Deferring to future release.
Comment 4 Red Hat Bugzilla 2006-02-21 13:48:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.