Bug 541353 - don't autostart nm-applet on KDE
don't autostart nm-applet on KDE
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks: F13blocker-KDE
  Show dependency treegraph
 
Reported: 2009-11-25 11:57 EST by Rex Dieter
Modified: 2010-02-10 13:58 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.8-0.3.git20100129
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-09 18:35:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2009-11-25 11:57:02 EST
We're planning on taking the plunge and use knetworkmanager by default for F-13, so please add
NotShowIn=KDE;
to
/etc/xdg/autostart/nm.applet.desktop
Comment 1 Rex Dieter 2009-11-25 11:58:01 EST
Since it's relatively easy, I can offer to flex my provenpackager muscles and just do it, if that's ok with you.
Comment 2 Kevin Kofler 2010-02-09 10:02:51 EST
So this still hasn't been implemented, it seems. We agreed again in today's KDE SIG meeting that this was the way forward for F13 and higher.
Comment 3 Kevin Kofler 2010-02-09 10:21:39 EST
I'm just committing and building this as it's trivial and only affects KDE, I hope I'm not hurting any feelings. :-)
Comment 4 Kevin Kofler 2010-02-09 10:31:19 EST
Oh joy, the build failed due to the DSO linking changes:
/usr/bin/ld: CMakeFiles/nmcli.dir/connections.c.o: undefined reference to symbol 'dbus_g_bus_get'
/usr/bin/ld: note: 'dbus_g_bus_get' is defined in DSO /usr/lib64/libdbus-glib-1.so.2 so try adding it to the linker command line
/usr/lib64/libdbus-glib-1.so.2: could not read symbols: Invalid operation
Comment 5 Kevin Kofler 2010-02-09 18:02:28 EST
I fixed that, now it fails in nm-connection-editor:
/usr/bin/ld: nm_connection_editor-page-wireless.o: undefined reference to symbol 'ceil@@GLIBC_2.2.5'
/usr/bin/ld: note: 'ceil@@GLIBC_2.2.5' is defined in DSO /lib64/libm.so.6 so try adding it to the linker command line
/lib64/libm.so.6: could not read symbols: Invalid operation
Comment 6 Kevin Kofler 2010-02-09 18:35:19 EST
I finally got it to build now.
Comment 7 Dan Williams 2010-02-10 13:58:31 EST
Pushed the -lm upstream in 1cc28feabf56a5a4ffb7f5cdf2881c7d06168628

Note You need to log in before you can comment on or make changes to this bug.