Bug 54139 - cannot display high resolutions on laptop with monitor
cannot display high resolutions on laptop with monitor
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-28 08:38 EDT by Alain Wenmaekers
Modified: 2008-01-25 14:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 15:18:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree.log when using a nokia monitor and the LCD screen switched off, selected resolution is 1024x768 (display not working) (28.98 KB, text/plain)
2001-10-02 02:23 EDT, Alain Wenmaekers
no flags Details
Xfree86.log (28.38 KB, text/plain)
2001-10-02 02:31 EDT, Alain Wenmaekers
no flags Details

  None (edit)
Description Alain Wenmaekers 2001-09-28 08:38:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2)
Gecko/20010726 Netscape6/6.1

Description of problem:
I'm using a Toshiba Tecra 8100 laptop with a Savage 3D video card. Through
the LCD screen, everything works fine (up to 1024*768). If set the adapter
on double display (both monitor and LCD) and put a monitor on the vga
adapter it display's fine on the monitor and the LCD (but it's limited to
1024*768 because of the LCD).
I can set the adapter on "monitor only" which should make it work as a
normal PC-VGA adapter (I want to use 1280*1024). 
If I launch Xconfigurator, it detects the monitor and the correct sync
info. However testing/running X just gives me a blank screen. Operating
info of the LG screen returns me an impossible sync frequency.
Going through the debug info of X, I see it detecting the LG and reporting
a "disabled" TFT/LCD. It even uses a correct sync mode... but it's not what
my screen is receiving. I can reproduce this in all resolutions (meaning
that even VGA does not work).
The resolutions do work in Windows.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Running Xconfigurator 
2. Run test or start X
3.
	

Actual Results:  Blank screen
LG Studioworks 775N (17") monitor reports incoming Sync of 10Khz and 15Hz.

Expected Results:  X on my screen

Additional info:

A collegue has the same problem using a Nokia 17" screen with an IBM
Thinkpad (ATI Rage Mobility). He's running Mandrake 8.0 and he tried both
4.0.3 ans 3.x drivers (with no success).
Comment 1 Alain Wenmaekers 2001-09-28 09:06:33 EDT
When booting in a framebuffer mode (vga=791), the console does display right 
(in 1024*768).
Starting X does not work.

So I guess it is not an adapter/driver error, but a problem with X.
Comment 2 Alain Wenmaekers 2001-10-02 02:23:45 EDT
Created attachment 33159 [details]
XFree.log when using a nokia monitor and the LCD screen switched off, selected resolution is 1024x768 (display not working)
Comment 3 Alain Wenmaekers 2001-10-02 02:31:42 EDT
Created attachment 33160 [details]
Xfree86.log
Comment 4 Mike A. Harris 2002-03-12 15:19:02 EST
Please try the XFree86 4.1.0 update which we released for RHL 7.1 and 7.2
not long ago, and see if that resolves this issue for you.
Comment 5 Alain Wenmaekers 2002-03-13 15:18:10 EST
RedHat 7.2 and Mandrake 8.1 behaves OK now on an IBM thinkpad with ATI Rage 
Mobility.

It also works OK (more or less) on a Toshiba 8100 with a Savage 3D, only 
quitting X give me a strange console back (but that could be because I didn't 
upgrade the kernel...)

You may consider it resolved

Grtz

Alain
Comment 6 David Lawrence 2008-01-25 14:54:53 EST
Comment on attachment 33160 [details]
Xfree86.log

Comment for attachment Xfree86.log:

Xfree86.log when LCD display AND monitor is on. The LCD is the primary display,
but the nokia monitor perfectly displays the screen too. Switching the LCD
display off and the nokia screen keeps displaying normally (an LG monitor
looses picture at this point)

Note You need to log in before you can comment on or make changes to this bug.