Bug 541548 - jmap fails: Could not find symbol "gHotSpotVMTypeEntryTypeNameOffset"
Summary: jmap fails: Could not find symbol "gHotSpotVMTypeEntryTypeNameOffset"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 12
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Andrew Haley
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-26 09:52 UTC by Maxim Valyanskiy
Modified: 2010-03-10 17:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 530402
Environment:
Last Closed: 2010-01-20 18:01:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Novell 530046 None None None 2019-04-02 14:48:13 UTC

Description Maxim Valyanskiy 2009-11-26 09:52:58 UTC
+++ This bug was initially created as a clone of Bug #530402 +++

Description of problem:
We are not able to get heap info by jmap tool because it crashes.

Version-Release number of selected component (if applicable):
# rpm -qa | grep openjdk
java-1.6.0-openjdk-1.6.0.0-1.2.b09.el5
java-1.6.0-openjdk-devel-1.6.0.0-1.2.b09.el5


How reproducible:
find java PID by "jps" and run "jmap -heap PID"


Actual results:
$ /usr/lib/jvm/java-openjdk/bin/jmap -heap 14715
Attaching to process ID 14715, please wait...
sun.jvm.hotspot.debugger.NoSuchSymbolException: Could not find symbol "gHotSpotVMTypeEntryTypeNameOffset" in any of the known library names (libjvm.so, libjvm_g.so, gamma_g)
        at sun.jvm.hotspot.HotSpotTypeDataBase.lookupInProcess(HotSpotTypeDataBase.java:388)
        at sun.jvm.hotspot.HotSpotTypeDataBase.getLongValueFromProcess(HotSpotTypeDataBase.java:369)
        at sun.jvm.hotspot.HotSpotTypeDataBase.readVMTypes(HotSpotTypeDataBase.java:102)
        at sun.jvm.hotspot.HotSpotTypeDataBase.<init>(HotSpotTypeDataBase.java:85)
        at sun.jvm.hotspot.bugspot.BugSpotAgent.setupVM(BugSpotAgent.java:568)
        at sun.jvm.hotspot.bugspot.BugSpotAgent.go(BugSpotAgent.java:494)
        at sun.jvm.hotspot.bugspot.BugSpotAgent.attach(BugSpotAgent.java:332)
        at sun.jvm.hotspot.tools.Tool.start(Tool.java:163)
        at sun.jvm.hotspot.tools.HeapSummary.main(HeapSummary.java:39)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at sun.tools.jmap.JMap.runTool(JMap.java:196)
        at sun.tools.jmap.JMap.main(JMap.java:128)
Debugger attached successfully.
sun.jvm.hotspot.tools.HeapSummary requires a java VM process/core!


Additional info:

--- Additional comment from therfert@redhat.com on 2009-10-27 14:08:07 EDT ---

Hello, you can find solution here:
https://bugzilla.novell.com/show_bug.cgi?id=530046#c3

--- Additional comment from therfert@redhat.com on 2009-11-04 12:20:10 EDT ---

Hello,
is any progress on this bug?
Tomas

Comment 1 Mark Wielaard 2009-11-26 10:08:59 UTC
The root cause for this seems to be that the HotSpotTypeDataBase doesn't know to search for the .symtab elf section in the debuginfo file, which it should get through either the original .gnu_debuglink section or the newer buildid note mechanism.
https://fedoraproject.org/wiki/Releases/FeatureBuildId

Comment 2 Andrew Haley 2009-12-16 17:54:26 UTC
There's now a patch for this upstream, and we'll push it to the Red Hat packages for the next release.

Comment 3 Andrew Haley 2010-01-20 18:01:12 UTC

*** This bug has been marked as a duplicate of bug 530402 ***

Comment 4 Andrew Haley 2010-03-10 17:00:01 UTC
Fixed in java-1.6.0-openjdk-1.6.0.0-34.b17.fc12.
You'll need to install the -debuginfo packages.


Note You need to log in before you can comment on or make changes to this bug.