Bug 541559 - Ctrl/Shift modifier keys appear stuck
Ctrl/Shift modifier keys appear stuck
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-26 05:29 EST by Tim Waugh
Modified: 2013-04-30 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: tigervnc-1.0.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 23:58:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2009-11-26 05:29:33 EST
Description of problem:
I'm seeing the problem described here:
  http://www.mail-archive.com/tigervnc-devel@lists.sourceforge.net/msg00452.html
Comment 1 smurffit 2010-01-04 12:00:26 EST
Well, i dunno if I'm right here, but i have a similar problem in Fedora 12.
Sometimes the keys are stuck until i press them again. I have noticed this with the ctrl, alt and w-a-s-d keys.

As a small workaround i tried to turn off the key-press-repeat in the keyboard preferences under Gnome. I unchecked the box "Key presses repeat when key is hold down". But this works only until the next reboot. The box stays unchecked but the keys can repeat again after a reboot.

I dunno which informations or details i could provide to solve this problem. :(
Comment 2 smurffit 2010-02-02 07:12:50 EST
Looks like it's fixed here, but dunno why :)
Comment 3 Adam Tkac 2010-02-02 07:23:27 EST
(In reply to comment #2)
> Looks like it's fixed here, but dunno why :)    

Would it be possible to tell me which version of tigervnc are you using, please?
Comment 4 smurffit 2010-02-02 07:34:36 EST
(In reply to comment #3)
> (In reply to comment #2)
> > Looks like it's fixed here, but dunno why :)    
> 
> Would it be possible to tell me which version of tigervnc are you using,
> please?    

Sorry, i had this problem in general not with vnc. :(
Comment 5 Fedora Update System 2010-04-14 08:16:08 EDT
tigervnc-1.0.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/tigervnc-1.0.1-1.fc12
Comment 6 Fedora Update System 2010-04-14 23:10:57 EDT
tigervnc-1.0.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tigervnc-1.0.1-1.fc12
Comment 7 Major 2010-05-01 18:31:48 EDT
I am seeing multiple misbehaviours of the control and shift key under F12; no VNC involved.

1. Autorepeating a control character, say Ctrl-P to go up in emacs, it will work for some number of characters and then forget that the control key is pressed and start inserting "p"s into my buffer

2. Hold down control and press a character, say Ctrl-C to terminate a command. Release both control and c. Most times the next character I type will be treated correctly but occasionally it, and any subsequent keys I press, will be interpreted as their control equivalent. The only way to fix it is to type the same character (in this case Ctrl-C) as started the problem.

3. Same as 2, but with shift

Happens with two different keyboards
Does not happen under F11 (on the same hardware)
Comment 8 Fedora Update System 2010-05-06 23:58:27 EDT
tigervnc-1.0.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.