Bug 54162 - rpm --rebuilddb fails
Summary: rpm --rebuilddb fails
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-29 09:13 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-03 15:59:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my rpm-database (4.04 MB, application/octet-stream)
2001-09-29 15:21 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-09-29 09:13:14 UTC
Description of Problem:
When trying to use rpm, gives error message 'free list corrupt (1391624)'
please run
rpm --rebuilddb
I tried, but it didn't help

Version-Release number of selected component (if applicable):
rpm 4.02

How Reproducible:
just running rpm again

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Need Real Name 2001-09-29 15:21:51 UTC
Created attachment 33020 [details]
my rpm-database

Comment 2 Jeff Johnson 2001-09-29 15:31:46 UTC
Try installing rpm-4.0.3-1.03.6x from
    ftp://ftp.rpm.org/pub/rpm/test-4.0.3

You will need to use rpm2cpio to install
    mkdir -p /var/tmp/xxx
    cd /var/tmp/xxx
    rpm2cpio rpm-4.0.3-1.03.6x.*.rpm | cpio -dim
    find . -type d -exec chmod 755 {} \;
    tar cf - ./usr ./etc | (cd /; tar xvf -)

Then do "rpm --rebuilddb" to fix your database.

Comment 3 Need Real Name 2001-10-01 15:57:31 UTC
Ok, I did it, but now when I do 'rpm --rebuilddb'
It gives this 14 times:

error: unrecognized db option: "verify" ignored
error: unrecognized db option: "tmpdir" ignored

And after that:
Segmentation fault (core dumped)

Comment 4 Jeff Johnson 2001-10-02 15:52:22 UTC
If you're seeing that message, you haven't invoked
rpm-4.0.3. Figure out what went wrong, and do
the --rebuilddb with rpm-4.0.3.

Comment 5 Need Real Name 2001-10-03 15:18:52 UTC
I'm such a newbie..
I executed /var/tmp/xx/bin/rpm --rebuild
Result was this:
/usr/lib/rpm/rpmd: error in loading shared libraries: /usr/lib/rpm/rpmd:
undefined symbol: poptAliasOptions

Has rpm-installation gone wrong? rpm --version was still 4.0.2.
/var/tmp/xxx/bin/rpm is 4.0.3


Comment 6 Jeff Johnson 2001-10-03 15:38:59 UTC
Ah yes, you'll need to install popt using rpm2cpio the same way.
Apologies for forgetting ....

Comment 7 Need Real Name 2001-10-03 15:59:36 UTC
OK!
rebuilddb works now.
Can I now install rpm and popt packages with rpm traditionally so that I can
avoid 'unrecognized db option' messages?

Comment 8 Jeff Johnson 2001-10-03 16:05:37 UTC
Yes, you need to reinstall rpm/popt packages the traditional way.

Reopen this bug if you need more.

Comment 9 Need Real Name 2001-10-03 17:21:35 UTC
Hi,
It's me again. What is best way to update rpm-related packages?
rpm -Uvh --force doesn't seem to work
error: failed dependencies:
	rpm = 4.0.2 is needed by rpm-python-4.0.2-6x
	rpm = 3.0.4 is needed by rpm-build-3.0.4-0.48
	rpm = 4.0.2 is needed by rpm-devel-4.0.2-6x
	rpm = 4.0.2 is needed by rpm-build-4.0.2-6x
	librpm.so.0 is needed by rpm-python-4.0.2-6x
	librpm.so.0 is needed by rpm-build-3.0.4-0.48
	librpm.so.0 is needed by rpm-python-3.0.4-0.48
	librpm.so.0 is needed by rpmfind-1.4-3
	librpm.so.0 is needed by nautilus-trilobite-1.0.2-ximian.2
	librpm.so.0   is needed by gnorpm-0.95.1-6.6x
	librpm.so.0 is needed by rpm-build-4.0.2-6x
	librpmbuild.so.0 is needed by rpm-build-3.0.4-0.48
	librpmbuild.so.0 is needed by rpm-build-4.0.2-6x
	librpmio.so.0 is needed by rpm-python-4.0.2-6x
	librpmio.so.0   is needed by gnorpm-0.95.1-6.6x
	librpmio.so.0 is needed by rpm-build-4.0.2-6x


Note You need to log in before you can comment on or make changes to this bug.