Bug 54163 - libcdaudio-1.0.0pre2 is source and binary incompatible with previous versions.
Summary: libcdaudio-1.0.0pre2 is source and binary incompatible with previous versions.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: libcdaudio (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: bero
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-29 11:54 UTC by ben.de.rydt
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 15:46:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ben.de.rydt 2001-09-29 11:54:51 UTC
Description of Problem:

libcdaudio-1.0.0pre2 is SOURCE and BINARY incompatible with the previous 
versions, but it does provide the same /usr/lib/libcdaudio.so.1.0.0.

This release can't be found on the sourceforge project page either.

Version-Release number of selected component (if applicable):
1.0.0pre2

How Reproducible:
Try building Audio::CD on CPAN (Perl) for instance. The build will fail 
because the header-file /usr/include/cdaudio.h changed. The names of a 
lot of structs changed, and some simply disappeared. If you have a 
previous version of Audio::CD installed (compiled against libaudiocd 
0.99.x) it will fail with a few unresolved symbols, because the 
/usr/lib/libcdaudio.so.1.0.0 of 1.0.0pre2 is not binary compatible with 
/usr/lib/libcdaudio.so.1.0.0 of 0.99.x.

Actions:
Please:
a) Warn the upstream provider of libcdaudio.
b) withdraw the libcdaudio-1.0.0pre2.
c) or, change the rpm so it puts the lib and header-files in non-standard 
locations, leaving the possibility to install both of libcdaudio-0.99.x 
and libcdaudio1-1.0.0pre2.

Comment 1 Tim Powers 2001-10-01 14:23:25 UTC
I have mailed the current maintainer asking what happened to the version which
was available at http://cdcd.undergrid.net/ (which not is unreachable). I'm
waiting for his response.

Tim

Comment 2 Bernhard Rosenkraenzer 2002-01-17 15:55:33 UTC
We never heard back from them; since Powertools has been discontinued, the "fix"
is that the package was removed.


Note You need to log in before you can comment on or make changes to this bug.