Bug 54164 - gnucash does not start at all
gnucash does not start at all
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnucash (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-29 09:36 EDT by Santeri Paavolainen
Modified: 2014-03-16 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-30 01:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gdb backtrace (1.86 KB, text/plain)
2001-09-29 09:37 EDT, Santeri Paavolainen
no flags Details
"strace -e open gnucash" (24.03 KB, text/plain)
2001-09-29 09:37 EDT, Santeri Paavolainen
no flags Details

  None (edit)
Description Santeri Paavolainen 2001-09-29 09:36:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20010921

Description of problem:
After installed gnucash-1.6.2-1.i386.rpm from Rawhide, and installing all
dependencies, gnucash does not start, but instead crashes while startup:

Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import exceptions' failed; use -v for traceback
Warning!  Falling back to string-based exceptions
'import site' failed; use -v for traceback
Fatal Python error: couldn't import os
zsh: abort (core dumped)  gnucash

I'll attach gdb backtrace and strace logs.

The problem is funny, since looking at the strace you can see it is looking
from python1.5 path, yet while installing I had to upgrade python, and it
is currently python-2.2-0.3a3 (from rawhide too). There is no python 1.5
installed (it was replaced by the 2.2) at all.  

So, either gnucash is compiled/configured incorrectly, or I have a
configuration problem with the system (PYTHONHOME is not set -- and setting
it to export PYTHONHOME=/usr/lib/python2.2 does not help), or there is a
missing dependency in gnucash RPM (to some python 1.5 compatibility thingie?).


Version-Release number of selected component (if applicable): 1.6


How reproducible:
Always

Steps to Reproduce:
1. run gnucash

Additional info:
Comment 1 Santeri Paavolainen 2001-09-29 09:37:05 EDT
Created attachment 33018 [details]
Gdb backtrace
Comment 2 Santeri Paavolainen 2001-09-29 09:37:42 EDT
Created attachment 33019 [details]
"strace -e open gnucash"
Comment 3 Bill Nottingham 2001-09-30 01:48:06 EDT
For the moment, you need to downgrade back to python 1.5.
Comment 4 Bill Nottingham 2002-01-24 23:33:50 EST
This will be fixed in gnucash-1.6.5-2.

Note You need to log in before you can comment on or make changes to this bug.