Bug 541685 - Following update of KDE 4.3.3 Issues with PYQT interface
Summary: Following update of KDE 4.3.3 Issues with PYQT interface
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eric
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-26 18:14 UTC by TR Bentley
Modified: 2009-12-11 18:24 UTC (History)
4 users (show)

Fixed In Version: 4.6.2-5.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-10 20:57:20 UTC
Type: ---


Attachments (Terms of Use)

Description TR Bentley 2009-11-26 18:14:04 UTC
Description of problem:
Running against the released updates to day a new version of KDE4.3.3 was release.
My Eric4 development environment now no longer works as the all the tree items no longer have text in them.
The application I an developing fails to load phonon even though it says it is present on the box.

Trying a new application and Eric is no longer useable.

getting error messages 

Warning: QVariant::save: unable to save type 256.


Version-Release number of selected component (if applicable):


How reproducible:
All the time


Steps to Reproduce:
1. Run Yum to upgarde to latest stable and use Eric of QT development from main repository.
2.
3.
  
Actual results:


Expected results:



Additional info:

Comment 1 TR Bentley 2009-11-27 17:57:18 UTC
Just patched my box to include PyQt4-4.6.2-3.fc12 and devel version and things are better but:
Eric from the repository still does not work.
Phonon is still not found .

Both were working fine up to the point the last KDE happened.

Comment 2 TR Bentley 2009-11-27 18:03:28 UTC
eric complains with

Warning:
QVariant::load: unable to load type 256.

Warning:
QVariant::save: unable to load type 256.

Comment 3 Rex Dieter 2009-11-27 23:14:48 UTC
$ rpm -q eric sip PyQt4 qt
eric-4.3.9-1.fc12.x86_64
sip-4.9.3-1.fc12.x86_64
PyQt4-4.6.2-3.fc12.x86_64
qt-4.5.3-9.fc12.x86_64

This combination works for me with eric.

Re: phonon, any test-case for that?
(for posterity, one issue per bug report please)

Comment 4 Rex Dieter 2009-11-27 23:22:00 UTC
Confirmed phonon is awol, from build.log:

Checking to see if the phonon module should be built...
g++ -DQT_NO_DEBUG -DQT_PHONON_LIB -I. -I/usr/lib64/qt4/mkspecs/default -I/usr/include/phonon -I/usr/include -I/usr/X11R6/include -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2  -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -w -D_REENTRANT cfgtest_phonon.cpp -o cfgtest_phonon -L/usr/X11R6/lib -Wl,-O1 -lphonon -lXext -lX11 -lm -lpthread
cfgtest_phonon.cpp:1:30: error: Phonon/VideoWidget: No such file or directory
cfgtest_phonon.cpp: In function 'int main(int, char**)':
cfgtest_phonon.cpp:5: error: expected type-specifier before 'Phonon'
cfgtest_phonon.cpp:5: error: expected ';' before 'Phonon'

Comment 5 Rex Dieter 2009-11-28 00:17:04 UTC
PyQt4 changelog:
* Fri Nov 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.6.2-4
- phonon bindings missing (#541685)

Still waiting on confirmation/details on eric failure(s).

Comment 6 Rex Dieter 2009-11-28 01:16:59 UTC
And, 
$ rpm -q qscintilla-python
qscintilla-python-2.4-7.fc12.x86_64

is required for proper eric function.

Comment 7 Fedora Update System 2009-11-28 01:41:48 UTC
PyQt4-4.6.2-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/PyQt4-4.6.2-5.fc12

Comment 8 Fedora Update System 2009-11-28 01:42:35 UTC
PyQt4-4.6.2-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/PyQt4-4.6.2-5.fc11

Comment 9 Fedora Update System 2009-11-28 01:45:29 UTC
PyQt4-4.6.2-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/PyQt4-4.6.2-5.fc10

Comment 10 TR Bentley 2009-11-28 14:35:41 UTC
Can confirm that Phonon now works on FC12 taking the patch from #7 above and installing it.

Still got problems with Eric which was working fine until KDE 4.3.3 arrived.

Warning:
An unhandled exception occurred. Please report the problem
using the error reporting dialog or via email to <eric4-bugs@die-offenbachs.de>.
A log has been written to "/home/timali/.eric4/eric4_error.log".
Error information:
--------------------------------------------------------------------------------
2009-11-28, 14:34:48
--------------------------------------------------------------------------------
<type 'exceptions.IndexError'>: 
sequence index out of range
--------------------------------------------------------------------------------
File "/usr/lib/python2.6/site-packages/eric4/eric4.py", line 136, in uiStartUp
mainWindow.performVersionCheck(False)
File "/usr/lib/python2.6/site-packages/eric4/UI/UserInterface.py", line 5160, in performVersionCheck
url = QUrl(self.__httpAlternatives[alternative])
--------------------------------------------------------------------------------
Version Numbers:
Python 2.6.2
KDE 4.3.3
PyKDE 4.0.2
Qt 4.5.3
PyQt4 4.6.2
sip 4.9.3
QScintilla 2.4
eric4 4.3.7.1 (r3372)
Platform: linux2
2.6.2 (r262:71600, Aug 21 2009, 12:23:57) 
[GCC 4.4.1 20090818 (Red Hat 4.4.1-6)]
--------------------------------------------------------------------------------
Plugins Version Numbers:
PluginAbout 4.3.0
PluginEricapi 4.3.0
PluginEricdoc 4.3.0
PluginProjectPylons 1.0.0
PluginPyLint 4.1.4
PluginRefactoringRope 1.1.5
PluginSyntaxChecker 4.2.0
PluginTabnanny 4.2.0
PluginVcsPySvn 4.3.0
PluginVcsSubversion 4.3.0
PluginVmListspace 4.2.0
PluginVmMdiArea 1.0.0
PluginVmTabview 4.3.0
PluginVmWorkspace 4.2.0
PluginWizardPyRegExp 4.2.0
PluginWizardQColorDialog 4.2.0
PluginWizardQFileDialog 4.2.0
PluginWizardQFontDialog 4.2.0
PluginWizardQInputDialog 4.2.0
PluginWizardQMessageBox 4.2.0
PluginWizardQRegExp 4.2.0
--------------------------------------------------------------------------------
Distribution Info:
/etc/redhat-release
Fedora release 12 (Constantine)
/etc/system-release
Fedora release 12 (Constantine)
/etc/fedora-release
Fedora release 12 (Constantine)

Comment 11 Rex Dieter 2009-11-28 15:37:18 UTC
rpm -q eric qt sip PyQt4 qscintilla-python PyKDE4 

please.

Also, does launching eric with:

eric4 --nokde

make any difference ?

Comment 12 TR Bentley 2009-11-28 15:50:39 UTC
As requested.  

[15:30][timali@tigger3] ~ $eric4 --nokde
QVariant::load: unable to load type 256.
QVariant::save: unable to save type 256.

[15:47][timali@tigger3] ~ $rpm -q eric qt sip PyQt4 qscintilla-python PyKDE4
eric-4.3.7.1-2.fc12.x86_64
qt-4.5.3-9.fc12.x86_64
sip-4.9.3-1.fc12.x86_64
PyQt4-4.6.2-5.fc12.x86_64
qscintilla-python-2.4-7.fc12.x86_64
PyKDE4-4.3.3-4.fc12.x86_64
[15:48][timali@tigger3] ~ $

Apart from upgrading PyQT4 from the pre release versions this is box has only been built 2 weeks and the only software installed from Fedora repositories.

Comment 13 Fedora Update System 2009-12-01 04:21:02 UTC
PyQt4-4.6.2-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PyQt4'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-12350

Comment 14 Fedora Update System 2009-12-01 04:21:52 UTC
PyQt4-4.6.2-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PyQt4'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12356

Comment 15 Fedora Update System 2009-12-01 04:31:34 UTC
PyQt4-4.6.2-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PyQt4'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12405

Comment 16 TR Bentley 2009-12-01 16:53:13 UTC
No change to the problem it still persists.
Update to Eric-3.3.9.1 has not helped.
Removed the .eric files from my home drive has not helped.

Comment 17 Rex Dieter 2009-12-01 16:59:43 UTC
I still cannot reproduce, let's consider this an eric-only issue for now.

Anyone else seeing this?

Comment 18 TR Bentley 2009-12-10 20:57:20 UTC
No sure what has happened it it has sorted it self out and has worked file for a week.
This bug can now be closed .

Comment 19 Fedora Update System 2009-12-11 18:13:55 UTC
PyQt4-4.6.2-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2009-12-11 18:20:45 UTC
PyQt4-4.6.2-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2009-12-11 18:24:21 UTC
PyQt4-4.6.2-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.