Bug 541694 - Review Request: php-phpunit-File-Iterator - FilterIterator implementation that filters files based on a list of suffixes
Review Request: php-phpunit-File-Iterator - FilterIterator implementation tha...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-26 13:34 EST by Christof Damian
Modified: 2009-12-04 18:56 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.1.0-4.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 18:56:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
fedora: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Christof Damian 2009-11-26 13:34:02 EST
Spec URL: http://rpms.damian.net/SPECS/php-phpunit-File-Iterator.spec
SRPM URL: http://rpms.damian.net/SRPMS/php-phpunit-File-Iterator-1.1.0-1.fc12.src.rpm
Description: FilterIterator implementation that filters files based on a list of suffixes
Comment 1 Christof Damian 2009-11-26 13:35:05 EST
This is a dependency for a new version of php-phpunit-phploc

rpmlint output: 
php-phpunit-File-Iterator.noarch: W: no-documentation
2 packages and 1 specfiles checked; 0 errors, 1 warnings.
Comment 2 Christof Damian 2009-11-26 16:02:45 EST
Spec URL: http://rpms.damian.net/SPECS/php-phpunit-File-Iterator.spec
SRPM URL:
http://rpms.damian.net/SRPMS/php-phpunit-File-Iterator-1.1.0-2.fc12.src.rpm

rpmlint output: 
php-phpunit-File-Iterator.noarch: W: no-documentation
2 packages and 1 specfiles checked; 0 errors, 1 warnings. 

updated files to allow older pear versions, also replaced some command with macros
Comment 3 Remi Collet 2009-11-28 02:55:40 EST
> BuildRequires:  php-pear >= 1.7.2

This is not correct because we have php-pear-4.3.9 in EL4

Shoud be 
BuildRequires:  php-pear >= 1:1.7.2
or
BuildRequires:  php-pear(PEAR) >= 1.7.2

+
Comment 4 Remi Collet 2009-11-28 03:00:11 EST
Please also requires php-common rather than php to avoid dependecy on httpd

+
Comment 5 Christof Damian 2009-11-28 04:03:09 EST
(In reply to comment #3)
> > BuildRequires:  php-pear >= 1.7.2
> 
> This is not correct because we have php-pear-4.3.9 in EL4
> 
> Shoud be 
> BuildRequires:  php-pear >= 1:1.7.2
> or
> BuildRequires:  php-pear(PEAR) >= 1.7.2

(In reply to comment #4)
> Please also requires php-common rather than php to avoid dependecy on httpd

I fixed both of these. New files:

Spec URL: http://rpms.damian.net/SPECS/php-phpunit-File-Iterator.spec
SRPM URL:
http://rpms.damian.net/SRPMS/php-phpunit-File-Iterator-1.1.0-3.fc12.src.rpm
Comment 6 Remi Collet 2009-11-28 09:03:19 EST
REVIEW:

+ rpmlint is ok
php-phpunit-File-Iterator.src: I: checking
php-phpunit-File-Iterator.noarch: I: checking
php-phpunit-File-Iterator.noarch: W: no-documentation
2 packages and 1 specfiles checked; 0 errors, 1 warnings.
+ package name ok
+ spec file name ok
+ package meet the PHP Guidelines 
+ License ok : BSD
+ License is upstream 
+ spec in english and legible
+ no license file in sources
+ sources match the upstream sources
8bd52abf03f3c8f86d296b4ee5d3d39d  File_Iterator-1.1.0.tgz
+ Source URL ok
+ build  on F12.x86_64
+ BuildRequires (php-pear >= 1:1.7.2, php-channel(pear.phpunit.de)) ok
+ no locale
+ no .so
- DONT own all directories that it creates
+ no duplicate file
+ %defattr ok
+ %clean section
+ use macros consistently
+ contain code
+ no documentation
+ no devel
+ no pkgconfig
+ no sub-package
+ no GUI
+ don't own files or directories already owned by other packages
+ %install start with rm -rf 
+ valid UTF-8
+ build in koji (dist-f13)
http://koji.fedoraproject.org/koji/taskinfo?taskID=1835237
+ no test suite
+ scriptlets ok
+ Final Requires ok
/usr/bin/pear  
php-channel(pear.phpunit.de)  
php-common >= 5.2.0
+ Final Provides ok
php-pear(pear.phpunit.de/File_Iterator) = 1.1.0
php-phpunit-File-Iterator = 1.1.0-3.fc8


Changing minimal dependency for PEAR seems acceptable as it's only for "installer"


MUST fix:
- own /usr/share/pear/File
Comment 7 Christof Damian 2009-11-30 07:03:17 EST
(In reply to comment #6)
> 
> MUST fix:
> - own /usr/share/pear/File  

I changed it to own all files and directories including and below /usr/share/pear/File

Spec URL: http://rpms.damian.net/SPECS/php-phpunit-File-Iterator.spec
SRPM URL:
http://rpms.damian.net/SRPMS/php-phpunit-File-Iterator-1.1.0-4.fc12.src.rpm
Comment 8 Remi Collet 2009-11-30 11:36:37 EST
All must fixed

***** APPROVED *****
Comment 9 Christof Damian 2009-11-30 11:53:08 EST
New Package CVS Request
=======================
Package Name: php-phpunit-File-Iterator
Short Description: FilterIterator implementation that filters files based on a list of suffixes  
Owners: cdamian
Branches: F-11 F-12 EL-5
InitialCC:
Comment 10 Kevin Fenzi 2009-12-03 01:26:23 EST
cvs done.
Comment 11 Fedora Update System 2009-12-03 02:44:38 EST
php-phpunit-File-Iterator-1.1.0-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/php-phpunit-File-Iterator-1.1.0-4.fc12
Comment 12 Fedora Update System 2009-12-04 18:56:49 EST
php-phpunit-File-Iterator-1.1.0-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.