Bug 54178 - freetype and type1 modules not loaded
freetype and type1 modules not loaded
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-30 13:23 EDT by Tobias Ringstrom
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-30 13:23:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Ringstrom 2001-09-30 13:23:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917

Description of problem:
The freetype and type1 modules are not loaded by default, which makes it
hard (if not impossible) for ordinary users to add truetype and type1 fonts
using "xset fp+".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to add a directory containing TrueType fonts using "xset fp+".

Additional info:
Comment 1 Mike A. Harris 2001-10-01 08:15:54 EDT
This is not a bug.  Red Hat Linux uses xfs as the font server.  xfs
handles Truetype and Type1 fonts.  The modules only need to be loaded
into the X server itself if the server is handling fonts itself, which
it is not in any default configuration.

The supported configuration, is using the xfs font server.  If you
disable xfs for whatever reason, or manually add font paths to the
X server's font path instead of to the xfs catalogues, then you
must to load the modules by adding the necessary lines to the X
server's config.  The same applies to using xset.

For details and help configuring XFree86 or xfs font server, please
consult the user support forums roswell-list@redhat.com and/or
xpert@xfree86.org.

Hope this helps.
Comment 2 Tobias Ringstrom 2001-10-01 08:34:13 EDT
No, it does not help, but thanks for your swift reply.  I must not have been 
clear enough, so please let me try again:

I know that the fonts are normally handled by the font server, and that the 
font server understands truetype and type1 fonts.  The problem is that only 
root can add fonts to the font server.  The xset method is the only way for 
ordinary users to add fonts dynamically.  I do think it is a very reasonable 
thing to do, to add fonts as a normal user, for example for GIMP usage.

I also know that the local admin could add the freetype and type1 modules, but 
I doubt most admins would do that unless requested.  I see no harm in having 
those modules loaded by default.  It's not like they require a lot of memory or 
other resources.

Another problem is that the error message you get when trying to add 
unsupported fonts is VERY hard to understand, even for an expert.

I hope this makes my wish more clear.
Comment 3 Mike A. Harris 2001-10-01 08:41:49 EDT
I understand your request.  It is not supported in the default
configuration.  The default configuration is suited towards the
general case.  Since it is impossible to have one configuration
that fits every possible user's usage patterns, a default has
to be set.  That default is to have xfs handle all font handling.
This suits the general case quite well, without loading extra
modules that are not necessary.

I consider this to be a localized non-general configuration issue.On most
systems which are using Linux for X desktops, the user of
the system is quite frequently 'root'.  On those where he/she is
not, the system administrator can modify the default configuration
to handle the special case IMHO.

Note You need to log in before you can comment on or make changes to this bug.