Bug 54186 - Strange behavior of globbing across file system
Strange behavior of globbing across file system
Status: CLOSED DUPLICATE of bug 73877
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-01 05:44 EDT by Jon Sporring
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Sporring 2001-10-01 05:44:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Dear RedHat

I'm experiencing something really strange:  I've mounted a directory from
our mainframe SGI running IRIX 6.5.  In my directory there are files called
main0{0,1,2,3,4}.pdf., however for some reason globbing cannot see
main01.pdf:

  [sporring@solsikke ~/lectures]$ ls main*.pdf
  main00.pdf  main02.pdf	main03.pdf  main04.pdf
  [sporring@solsikke ~/lectures]$ ls main01.pdf
  main01.pdf

I've tested several SGI's all running IRIX 6.5 and all showing same
behavior.  I experience something similar with gFTP, where the file is
invisible in the 'local' subwindow but not in the 'remote' subwindow. 
However I don't experience this when the files are copied to a local
directory:

  [sporring@solsikke tmp]$ ls main*.pdf
  main00.pdf  main01.pdf	main02.pdf  main03.pdf	main04.pdf

Thus, it seems to be the connection Linux<->IRIX.  Do you have an idea to
what could be wrong?

Thanks, Jon Sporring


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Produce files on SGI called main0{0,1,2,3,4}.pdf
2. mount directory on Linux
3. ls main*.pdf
	

Actual Results:  Globbing does not produce the file main01.pdf

Expected Results:  It should have!

Additional info:

See description
Comment 1 Laurent CREPET 2001-10-01 13:47:46 EDT
I discover such a problem this morning (NFS client under RH 7.1, kernel 2.4.2 RH, 
NFS server under Irix 6.5.2m). Using tcsh, a directory was missing when using 
completion. I have no problem with bash (using strace showed me that tcsh use a 
different way than bash to list directory contents (more operations)).

I had the same problem under Mandrake (sorry to speak about...), with kernel 2.4.2. I 
upgraded it with 2.4.7, and the problem disappeared. I'll have a look at my RH 7.1 
system to see 2.4.3 RH will fix the problem, or I'll install a custom kernel.

Comment 2 Joe Krahn 2001-10-31 20:20:53 EST
This was a known bug relating to 32 bit Linux clients and 64 bit IRIX servers.
There was a work-around patch for Linux, but the real solution is to upgrade to
IRIX 6.5.13, and possibly add the 32bitclients flag to IRIX exports. (You'll
find that IRIX and Linux are poor NFS partners).

Joe Krahn
Comment 3 Michael Plass 2001-11-21 03:52:04 EST
I've upgraded my IRIX system to 6.5.13m and set the 32bitclients option but it
doesn't help. Do you have any other ideas?

Michael Plass
Comment 4 Miloslav Trmač 2004-08-17 09:11:26 EDT

*** This bug has been marked as a duplicate of 73877 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:48:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.